aspose file tools*
The moose likes JBoss/WildFly and the fly likes jboss-ide ClassNotFoundException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "jboss-ide ClassNotFoundException" Watch "jboss-ide ClassNotFoundException" New topic
Author

jboss-ide ClassNotFoundException

jim stone
Greenhorn

Joined: Apr 26, 2005
Posts: 18
I'm trying to start the jboss 4.0 server using the debug feature of jboss-ide. When it starts up, I get a ClassNotFoundException on a utility class that I created that is used by the session ejb. The utility class is part of a jar file called utility.jar. This utility.jar file is contained in the ejb jar file. I can't seem to figure out why I'm getting the error if everything is located in the jar files. I created the utility.jar file using the jboss-ide packaging configuration. I then added the utility.jar to the ejb jar file using the packaging configuration. I was able to get this all to work in a project that had only one .war file and the ejb jar file. Once I added the utility.jar in the same project as the web and ejb code, I'm getting the ClassNotFoundException. Just curious if anyone else has recieved this before.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: jboss-ide ClassNotFoundException
 
Similar Threads
Eclipse EJB doesn't update manifest file?
Instantiating classes in jar file used by Web project
Creating a Jar (NON executable) with all the dependencies
log4j setting in enterprise project structure
JBoss again...