wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes Problem in JBOSS hot deployment... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Problem in JBOSS hot deployment..." Watch "Problem in JBOSS hot deployment..." New topic
Author

Problem in JBOSS hot deployment...

Pras Tiwari
Ranch Hand

Joined: Nov 07, 2005
Posts: 186
Hi,

I am developing a web application using Struts. I am using JBOSS 4.0.3RC1 as app server. The problem is that when I start up the server for the first time & deploy the web application it deployed successfully through JBOSS IDE for eclipse. But when I am updating my web application (modifying some JSP's) the hot deployment not take place. Also When I m trying to redeploy/remove it through deployment box in eclipse it gives me error like:-
=============
Deployment is out of date due to changes in underlying project content.You'll need to manually 'Redeploy'the project to update deployed archive.
=============

Where is the proble??? Also when I restart server it works fine for the first time.
Please help me.
Thanx in advance.
Prash


********Deserve Before You Desire********
 
Consider Paul's rocket mass heater.
 
subject: Problem in JBOSS hot deployment...
 
Similar Threads
JSP Exception only on JBoss not Tomcat?
How to run Web Application in ItellijIDEA
Hot deployment issue in JBOSS??
JBoss doesn't automaticaly detecting source code changes
JBoss IDE for eclipse - EJB 3.0 support