aspose file tools*
The moose likes JBoss/WildFly and the fly likes JBoss Follows it's own J2EE Specification Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss Follows it Watch "JBoss Follows it New topic
Author

JBoss Follows it's own J2EE Specification

saikrishna cinux
Ranch Hand

Joined: Apr 16, 2005
Posts: 689
hi to all,

I am running my webapplication in both tomcat4.0 and jboss4.0.3 sp1 it runs fine in tomcat but it doesn't run properly in JBoss

i mean JBoss uses it's own specification for compiling the jsp pages into servlet..

The problem in running my application in jboss server is it just displays the jsp's in different way..

why it does like that???
can any one plesae tell me >???

Actually i want the answer from the developers of JBoss but any experienced JBoss user can answer my question

thanking u in advance

cinux


A = HARDWORK B = LUCK/FATE If C=(A+B) then C=SUCCESSFUL IN LIFE else C=FAILURE IN LIFE
SCJP 1.4
Paul Sturrock
Bartender

Joined: Apr 14, 2004
Posts: 10336


runs fine in tomcat but it doesn't run properly in JBoss

Can you explain the differences? Its a little hard to understand what the problem is from your description.


mean JBoss uses it's own specification for compiling the jsp pages into servlet..

JBoss 4 is a J2EE 1.4 certified application server, which means that though how it implements things will be different, how it behaves with regards to the specification will be the same as any other certified application server.

JBoss does not compile any web components directly. It ships with Tomcat as its servlet container. In the case of JBoss 4 it is Tomcat 5 it ships with (I don't think it has shipped with v4.0 since version 2.something). So you are looking at JSPs compiled in different versions of Tomcat; JBoss doesn't com into this.


Actually i want the answer from the developers of JBoss

Thought threre are a few JBoss staff kicking around these forums (from whom you may get an answer), if you really want an answer from a member of JBoss staff you will need to contact JBoss directly.
[ May 12, 2006: Message edited by: Paul Sturrock ]

JavaRanch FAQ HowToAskQuestionsOnJavaRanch
Henrique Sousa
Ranch Hand

Joined: Apr 29, 2004
Posts: 92
In the case of JBoss 4 it is Tomcat 5 it ships with (I don't think it has shipped with v4.0 since version 2.something).

If I am not mistaken, JBoss was shipped with Tomcat 4 up to 3.2.1 or 3.2.3. Version 3.2.4 most certainly is shipped with Tomcat 5


Henrique Sousa<br />SCJP 1.4<br /> <br />All men die, not all men really live - Braveheart, 1995
saikrishna cinux
Ranch Hand

Joined: Apr 16, 2005
Posts: 689
Yes, U r perfectly right sir, Jboss internally makes use of tomcat5
so, i laso ran the same application deploying it into tomcat5

the same problem with the tomcat5.0 too :-(



what to do..
i am explaining abt my application here

my application deals with an online examination which display's some set of questions and also it diplays result and review of the questions.
so the problem is in the review section it actulayy displays the user answer and the actual answer (displaying red and green blocks over the choices) so in tom cat it displays fine but with tomcat5 it displays everyting red blocks or everything green blocks over the choices

if my programming logic is wrong then it must display the same with tomcat4

what might be the problem..
please help me out ASAP


thans in advance

cinux
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10285
    
169

This looks more like a question on JSP. The guys in the JSP forums would have a better knowledge in answering this.


[My Blog] [JavaRanch Journal]
saikrishna cinux
Ranch Hand

Joined: Apr 16, 2005
Posts: 689
ok sombody help me out to move this thread to jsp forums
otherwise can anybody tell me why it is happening like this i think tomcat5.0 and jboss must be following some other server strategies that is why my applcaition is not working properly
am i right :roll:
Paul Sturrock
Bartender

Joined: Apr 14, 2004
Posts: 10336


ok sombody help me out to move this thread to jsp forums
otherwise can anybody tell me why it is happening like this i think tomcat5.0 and jboss must be following some other server strategies that is why my applcaition is not working properly
am i right

Post the code that is causing the behaviour then we can decide if this need moved to a more appropriate forum (since currently I'm not sure which forum best suits this question). It is very difficult to guess what might be causing this without seeing the code.
saikrishna cinux
Ranch Hand

Joined: Apr 16, 2005
Posts: 689
boss i am pretty sure tht the problem is with servers not with m y programming logic coz it runs fine in tomcat4.0 but it doesn't in tomcat5.0
so i am sure tht tomcat5.0 has modified it's technology
Paul Sturrock
Bartender

Joined: Apr 14, 2004
Posts: 10336


so i am sure tht tomcat5.0 has modified it's technology

You may be right. But without knowing what it was you were trying to do that exhibits the different behaviours then no one can help.
saikrishna cinux
Ranch Hand

Joined: Apr 16, 2005
Posts: 689
ok boss here i am copying my code
u open it any ide's for viewing the html code
jsut click on radio button see the code


sorry i am unable to copy my code here it is diplsying some error msg
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JBoss Follows it's own J2EE Specification