aspose file tools*
The moose likes JBoss/WildFly and the fly likes Strange deployment behavior Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Strange deployment behavior" Watch "Strange deployment behavior" New topic
Author

Strange deployment behavior

Mike London
Ranch Hand

Joined: Jul 12, 2002
Posts: 1075
How is it possible that when I run an EAR file on one JBOSS installation, it works fine, but on anther JBOSS installation, I get ClassNotFound erorrs?

Both versions of JBOSS are the same (4.03 SP1) and both installations have the same Java code, however one box has Java 1.5, the other has Java 1.4.

The EAR that won't run on the Java 1.4 box runs fine on the Java 1.5 box and the EAR created on the Java 1.5 box runs fine there too.

I've spent countless hours now trying to figure this out.

I'm using Maven to build the EAR file. The project complaining about the ClassNotFoundException is in the tmp\deploy area of the deployment.

HELP!!!

Thanks.

-- Mike
Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17257
    
    6

Maybe you are using a 5.0 class that isn't available in 1.4 Or maybe you compiled in 5.0 but tried to run it on a 1.4 JVM. Or maybe the 1.4 box ia missing a jar file that is a dependency.

Mark


Perfect World Programming, LLC - Two Laptop Bag - Tube Organizer
How to Ask Questions the Smart Way FAQ
Mike London
Ranch Hand

Joined: Jul 12, 2002
Posts: 1075
I'm cool with the JDK differences and understand how these errors could happen.

Here's where I need you clarification: --- how it is possible that the EAR file could be missing a jar dependency on one machine, but (the same EAR file) run fine on another? That seems to be what's happening though.

The way I think about the EAR file is that it has EVERYTHING it needs -- the entire application -- to run and should work on any JBOSS installation (it has all dependencies within the EAR).

I build the EAR on the PC that won't run it, but it runs fine on another PC. How can this be? I even know which JAR/class it's complaining about, but I'm baffled how this can happen in the first place.

I really look forward to your reply. I'm clearly missing something basic on JBOSS deployments.

Thanks in advance.

-- Mike
Dave Salter
Ranch Hand

Joined: Jul 20, 2005
Posts: 293

Do you have any dependencies for the EAR file in the JBoss/server/../lib directory that may be one one PC and not the other?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Strange deployment behavior