This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes JBoss/WildFly and the fly likes Eclipse 3.2 error when using JBoss 4.0.5.GA Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Eclipse 3.2 error when using JBoss 4.0.5.GA" Watch "Eclipse 3.2 error when using JBoss 4.0.5.GA" New topic
Author

Eclipse 3.2 error when using JBoss 4.0.5.GA

Melinda Savoy
Ranch Hand

Joined: Jun 21, 2005
Posts: 387

One question I guess I should have asked those in this forum before I posed my question below is what IDE do you guys use with JBoss? Do you use JBoss Eclipse or just Eclipse or other? If you use JBoss Eclipse is that because the "regular" Eclipse will not work with JBoss?


Our dev team just installed Eclipse 3.2 and JBoss 4.0.5.GA on our local Window XP
machines.

When selecting a JSP page from within the Eclipse 3.2 IDE and then I right-click to "run on server" I am getting the following error:

HTTP Status 500 -

type Exception report
message
description The server encountered an internal error () that prevented it from
fulfilling this request.
exception
java.lang.NullPointerException
org.jboss.mx.loading.RepositoryClassLoader.findClass(RepositoryClassLoader.java:620)
java.lang.ClassLoader.loadClass(Unknown Source)
org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryClassLoader.java:464)
org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassLoader.java:405)
java.lang.ClassLoader.loadClass(Unknown Source)
java.lang.ClassLoader.loadClassInternal(Unknown Source)
org.acegisecurity.ui.ntlm.NtlmProcessingFilter.onPreAuthentication(NtlmProcessingFilter.java:344)
org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:200)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:110)
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:191)

org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:90)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
note The full stack trace of the root cause is available in the Apache
Tomcat/5.5.20 logs.

It appears(?) that the issue is that Eclipse will rebuild and redeploy the EAR
to JBoss while at the same time opening up IE and trying to load the JSP. JBoss
eventually will see the new EAR and it has to go through a process of unloading
the current EAR from memory and then reloading the new EAR. The error I see is
happening when JBoss unloads the current EAR from memory as far as I can tell.

I submitted this problem to Eclipse but they said it is a problem with JBoss. I submitted a bug report to JBoss but I'm on a really long list.

Any suggestions or direction would be greatly appreciated.

Regards.
[ November 17, 2006: Message edited by: Melinda Savoy ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse 3.2 error when using JBoss 4.0.5.GA