Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

getting error when involking jsp file.

 
Milan Jagatiya
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
good morning.

I am new to JBoss AS. I think I have instal jboss-4.0.4.GA successfully by "JEMS Installer 1.2.0BETA3 Installer" from http://labs.jboss.com/portal/jemsinstaller/downloads/

I am using MyEclipse 4 for development and Apache tomcat 5.5.7. but now i want to deploy my application with JBoss. I have build a testing project and deploy with Apache Tomcat , it works okeyy. but now i am deploying it with JBoss and when i involk my projects jsp file "http://localhost:8080/mypager/pager-demo.jsp" i am getting following error. the same error getting for
"http://localhost:8080/web-console/" .



can you describe this error..please give me the description. help me to out...

thanks in advance...

good day.
milan
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"milan"

Please click on the My Profile link above and change your display name to meet the JavaRanch Naming Policy of using your real first and real last name.

Thanks

Mark
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you moved all the needed jar files to JBoss?

Mark
 
Milan Jagatiya
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,
thanks for reply...

i am using ms sql server . so i placed jars for ms sql server in
C:\jboss-4.0.4.GA\server\default\lib

is any other jar i need to place ???

milan.
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
org.eclipse.jdt.internal.compiler.env.NameEnvironmentAnswer

This looks like an eclipse class that is causing the problem. I do not know much about eclipse, to let alone know why a deployment needs an eclipse class?

Mark
 
Milan Jagatiya
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,

is it because of I am deploying my project through myEclipse???

okeyyy...i think i should deploy manually...lets see....hope it works...

thanks for your kind reply..

milan.
 
Milan Jagatiya
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
or is it becauase of any CLASSPATH variable missing there???

milan.
 
Milan Jagatiya
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got below line from log file when starting JBoss service.



can you please describe what it says??? milan.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic