jQuery in Action, 2nd edition*
The moose likes JBoss/WildFly and the fly likes Setting Load balancer for JBoss using Apache and mod_jk Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Setting Load balancer for JBoss using Apache and mod_jk" Watch "Setting Load balancer for JBoss using Apache and mod_jk" New topic
Author

Setting Load balancer for JBoss using Apache and mod_jk

Kshitija Ambulgekar
Greenhorn

Joined: Aug 27, 2006
Posts: 24
Hi,

I am trying to set loadbalancer for JBoss using Apache and mod_jk.
1) I have modified httpd.conf file by adding following line at end:
Include APACHE_HOME/conf/mod-jk.conf

2) created APACHE_HOME/conf/mod-jk.conf file
3) Created APACHE_HOME/conf/workers.properties file
4) Created APACHE_HOME/conf/uriworkermap.properties file
5) Placed mod_jk.so in APACHE_HOME/modules folder

When I am starting the Apache server, it is giving me error saying:
"Cannot load C:/Program Files/Apache Group/Apache2/modules/mod_jk.so into server:The specified module could not be found."

Can somebody help on this? I am badly stuck on this problem.
Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17260
    
    6

Can you post what you have in your APACHE_HOME/conf/mod-jk.conf file?

Also your workers.properties too, just in case.

Mark


Perfect World Programming, LLC - Two Laptop Bag - Tube Organizer
How to Ask Questions the Smart Way FAQ
Kshitija Ambulgekar
Greenhorn

Joined: Aug 27, 2006
Posts: 24
Contents of mod-jk.conf are



workers.properties

Mark Spritzler
ranger
Sheriff

Joined: Feb 05, 2001
Posts: 17260
    
    6

First, is this your actual IP/URL address of the App Servers you want to forward to, node1.mydomain.com?

worker.node1.host=node1.mydomain.com

Also, it looks like the loading part of the module, the line in the mod_jk.conf file is commented out

#LoadModule jk_module modules/mod_jk.so This line is included in httpd.conf file

You had only mentioned in the first post of this thread that you only added this line below

Include APACHE_HOME/conf/mod-jk.conf

which just includes the conf file, not load the module

Mark
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Setting Load balancer for JBoss using Apache and mod_jk