This week's book giveaway is in the Cloud/Virtualizaton forum.
We're giving away four copies of Mesos in Action and have Roger Ignazio on-line!
See this thread for details.
Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Configuring JBoss to run jBpm

 
Eugene Abarquez
Ranch Hand
Posts: 211
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello to any JBoss experts in the house,

I want to know how to configure my older version of JBoss to run jBpm, specifically jboss-4.0.3. I was able to run the sample web application that comes bundled with the starters kit, but that was using the jboss server in the starters kit. I want to know how I can do the same thing using my jboss-4.0.3 server. Is that possible at all? I tried to deploy the sample web application WAR file in my jboss-4.0.3 server, but it is giving me some wierd errors. Please advise. Thanks.
 
Eugene Abarquez
Ranch Hand
Posts: 211
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Any ideas?
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I havent used JBoss jBpm. The starters kit that i downloaded contains a jbpm.war and a jbpm.sar (and maybe something more). So when you say:

I tried to deploy the sample web application WAR file in my jboss-4.0.3 server


Did you even copy the sar? I dont know whether that's required, but you could give it a try. Also what's the exception that you are seeing? I would expect it to run on any other instance of JBoss as long as you make sure you have deployed all the required archives.
 
Eugene Abarquez
Ranch Hand
Posts: 211
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Jaikiran,

Thanks for the reply. This worked for me. I added the jbpm.sar folder together with the jbpm-ds.xml and jbpm.war files in the deploy folder of jboss-4.0.3. The jbpm sample web application page is now showing, but it throws an exception when you navigate to a page with the process definition graph image with it, i.e. the task.jsp page. It might be an issue with the version of the jar files used. Anyway, I will have to look more into it. But thanks a lot though for the help.

Cheers!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic