aspose file tools*
The moose likes JBoss/WildFly and the fly likes installing and configuring jboss Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "installing and configuring jboss" Watch "installing and configuring jboss" New topic
Author

installing and configuring jboss

nandan johri
Ranch Hand

Joined: Jan 12, 2006
Posts: 75
i tried ti install jboss on my system but on installing and typing run.bat and i getting the following exeception:

I have the websphere installed on my system and my JAVA_HOME is pointing to the jre v5.1.2 in websphere only .

CMD:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

D:\Documents and Settings\nandan.johri>c:

C:\>cd program files

C:\Program Files>cd jboss5

C:\Program Files\jboss5>cd bin

C:\Program Files\jboss5\bin>dir
Volume in drive C is GWCS61
Volume Serial Number is 785B-0381

Directory of C:\Program Files\jboss5\bin

05/05/2007 04:27 PM <DIR> .
05/05/2007 04:27 PM <DIR> ..
10/24/2005 03:22 AM 3,539 classpath.sh
10/24/2005 03:22 AM 1,671 deployer.bat
10/24/2005 03:22 AM 2,649 deployer.sh
10/24/2005 03:22 AM 2,463 jboss_init_redhat.sh
10/24/2005 03:22 AM 3,750 jboss_init_suse.sh
10/24/2005 03:22 AM 3,140 run.bat
10/24/2005 03:22 AM 1,491 run.conf
10/24/2005 03:22 AM 37,292 run.jar
10/24/2005 03:22 AM 4,672 run.sh
10/24/2005 03:22 AM 1,813 shutdown.bat
10/24/2005 03:22 AM 16,984 shutdown.jar
10/24/2005 03:22 AM 2,008 shutdown.sh
10/24/2005 03:23 AM 2,137 twiddle.bat
10/24/2005 03:23 AM 42,789 twiddle.jar
10/24/2005 03:23 AM 2,414 twiddle.sh
15 File(s) 128,812 bytes
2 Dir(s) 458,117,120 bytes free

C:\Program Files\jboss5\bin>run.bat
===============================================================================
.
JBoss Bootstrap Environment
.
JBOSS_HOME: C:\Program Files\jboss5\bin\\..
.
JAVA: C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\eclip
se\jre\bin\java
.
JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
.
CLASSPATH: C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\
eclipse\jre\lib\tools.jar;C:\Program Files\jboss5\bin\\run.jar
.
===============================================================================
.
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/jboss/Mai
n (Unsupported major.minor version 48.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:703)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:13
3)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:320)
at java.net.URLClassLoader.access$400(URLClassLoader.java:93)
at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:678)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:239)
at java.lang.ClassLoader.loadClass(ClassLoader.java:516)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:460)
at java.lang.ClassLoader.loadClass(ClassLoader.java:448)
Press any key to continue . . .


please help me in what is going on here and how to fix .I have tried installing different versions of jboss and every time its throwing the same error.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10102
    
165

Looks like you are using JBoss5 with JDK1.3 (which comes with WebSphere). You will have to use a minimum of JDK1.4 for this version of JBoss. Have a look at JBossVsJavaJDKVersionMatrix for more details


[My Blog] [JavaRanch Journal]
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10102
    
165

Read your post again. You mention:

and my JAVA_HOME is pointing to the jre v5.1.2


I'm not sure that's correct. From the command prompt go to C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\eclipse\jre\bin\ and run the following command:



That will show you the version of Java being used
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: installing and configuring jboss