File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes HTTPS on JBoss/Tomcat - SSL is *hard* to setup!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "HTTPS on JBoss/Tomcat - SSL is *hard* to setup!!" Watch "HTTPS on JBoss/Tomcat - SSL is *hard* to setup!!" New topic
Author

HTTPS on JBoss/Tomcat - SSL is *hard* to setup!!

Vinnie Jenks
Ranch Hand

Joined: Apr 26, 2004
Posts: 207
I'm having a really hard time getting an SSL cert installed correctly and I obviously don't understand what's involved because I'm finding a myriad of information on Google on how this is done and just as many people who are having the same problems I am w/ all different versions of JBoss & Tomcat.

I'm using JBoss 4.0.4.GA, which uses Tomcat 5.5.17. I have an SSL cert from Verisign for which I'm trying to install.

I followed these instructions:

http://docs.jboss.org/jbossas/jboss4guide/r4/html/ch9.chapt.html#d0e21962

...and I followed this for setting up the cert:

http://www.verisign.com/support/ssl-certificates-support/install-ssl-certificate.html
http://www.verisign.com/support/ssl-certificates-support/page_dev020195.html

...but no matter what, when starting JBoss I get these errors:



I've been banging on this for two days now and at this point I may have no choice but to run JBoss through IIS since it's running on the same machine. I don't *want* to do that but this is overwhelming. I haven't been able to find a post or get a response on the JBoss AS forums to help me out.

Can anyone help me out?
Jessica Plunkett
Greenhorn

Joined: Aug 20, 2007
Posts: 7
Vinnie - I know that this is a very old thread but I have the same problem that you described in your post and I was wondering if you ever found a solution? Thanks in advance.
Vinnie Jenks
Ranch Hand

Joined: Apr 26, 2004
Posts: 207
Originally posted by Jessica Plunkett:
Vinnie - I know that this is a very old thread but I have the same problem that you described in your post and I was wondering if you ever found a solution? Thanks in advance.


Actually, yes, we've been running in production and SSL has been working since I posted this. With some trial-and-error, it came together.

Shoot me an email at zambizzi-at-gmail-dot-com and I'll try to help you where you're stuck.

-v
Bert Bates
author
Sheriff

Joined: Oct 14, 2002
Posts: 8813
    
    5
moving to servlets forum


Spot false dilemmas now, ask me how!
(If you're not on the edge, you're taking up too much room.)
Vinnie Jenks
Ranch Hand

Joined: Apr 26, 2004
Posts: 207
Originally posted by Bert Bates:
moving to servlets forum


Bert - is it a slow day on the board? This has nothing to do w/ Servlets and everything to do w/ an app server.
 
Don't get me started about those stupid light bulbs.
 
subject: HTTPS on JBoss/Tomcat - SSL is *hard* to setup!!