Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBoss installation problems

 
Sen Aff
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello People,

I am trying to install JBoss and I had this error when
I tried to start the server.

Failed to boot JBoss:
org.jboss.deployment.DeploymentException: url file:/C:/Program Files/JBoss/jboss-4.2.1.GA/server/default,all,minimal,other/conf/jboss-service.xml could not be opened, does it exist?

Can anyone please help me out?

Thanks a lot in advance.

Sen Aff.
 
Elias Ross
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
On Windows, I suggest you extract your JBoss install to a directory off of root without spaces, e.g. c:/bin/jboss-4.2.1GA.

And every time, post the exact error message quoted with the command you ran.
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also, how did you install JBoss? How are you starting it? As Elias mentioned, please post the entire exception stacktrace and the initial startup logs from the server.log file.
 
Sen Aff
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I am using Eclipse Europa. I downloaded the zip file and decompressed it.
Then I copied the unzipped(jboss-4.2.1.GA) file to C:\Program Files\JBoss.

From my eclipse IDE i created a J2EE project specifying JBoss as my server.
When I started the server, it failed.

This is the entire stack trace.

Failed to boot JBoss:
org.jboss.deployment.DeploymentException: Not pointing to a directory, url: file:/C:/Program Files/JBoss/jboss-4.2.1.GA/server/default,all,minimal,other/lib/; - nested throwable: (java.io.FileNotFoundException: Not pointing to a directory, url: file:/C:/Program Files/JBoss/jboss-4.2.1.GA/server/default,all,minimal,other/lib/)
at org.jboss.deployment.SARDeployer.init(SARDeployer.java:217)
at org.jboss.deployment.MainDeployer.init(MainDeployer.java:872)
at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:809)
at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:782)
at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:766)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.java:142)
at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
at $Proxy5.deploy(Unknown Source)
at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:482)
at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)
at org.jboss.Main.boot(Main.java:200)
at org.jboss.Main$1.run(Main.java:508)
at java.lang.Thread.run(Thread.java:619)
Caused by: java.io.FileNotFoundException: Not pointing to a directory, url: file:/C:/Program Files/JBoss/jboss-4.2.1.GA/server/default,all,minimal,other/lib/
at org.jboss.net.protocol.file.FileURLLister.listMembers(FileURLLister.java:68)
at org.jboss.net.protocol.URLListerBase.listMembers(URLListerBase.java:52)
at org.jboss.net.protocol.URLListerBase.listMembers(URLListerBase.java:57)
at org.jboss.deployment.SARDeployer.parseXMLClasspath(SARDeployer.java:558)
at org.jboss.deployment.SARDeployer.init(SARDeployer.java:193)
... 23 more


Thank you very much.

Sen Aff.
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I havent tried using JBoss with Eclipse. A few things that you could try:

1) As Elias mentioned, install JBoss in a folder which does not have a space in its path (Ex: C:\JBoss). This is true for other Java applications as well.

2) Point JAVA_HOME to JDK5 installation

3) Try starting JBoss, through the console, using the run.bat file present in the bin folder of JBoss installation

4) Make sure that the zip file that you downloaded is not corrupted. Does it indeed have the jboss-service.xml file in server/default/conf folder? Or is it missing that file (in which case the downloaded zip might be corrupted). Redownloading may solve the issue.
 
Sen Aff
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks a lot people,

the JBoss server starts now...i think it was the space issue.

Sen Aff.
 
Abhi Bose
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Steps I followed
1. Modified the Server configuration to default.
2. Deleted the JBOSS Server
3. Added a new server
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic