aspose file tools*
The moose likes JBoss/WildFly and the fly likes Error whiling running the server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Error whiling running the server" Watch "Error whiling running the server" New topic
Author

Error whiling running the server

ankush patni
Greenhorn

Joined: Oct 11, 2007
Posts: 11
Hi All,
When i am running my jboss server i am getting following error.


11:05:11,440 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

--- Packages waiting for a deployer ---
org.jboss.deployment.DeploymentInfo@e9697f70 { url=file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/MANIFEST.MF }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/MANIFEST.MF
altDD: null
lastDeployed: 1193290511425
lastModified: 1193290511425
mbeans:

org.jboss.deployment.DeploymentInfo@c97846f6 { url=file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/ra.xml }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/ra.xml
altDD: null
lastDeployed: 1193290511440
lastModified: 1193290511425
mbeans:

org.jboss.deployment.DeploymentInfo@c8309f54 { url=file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jndi.properties }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jndi.properties
altDD: null
lastDeployed: 1193290511440
lastModified: 1193290511440
mbeans:

--- Incompletely deployed packages ---
org.jboss.deployment.DeploymentInfo@e9697f70 { url=file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/MANIFEST.MF }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/MANIFEST.MF
altDD: null
lastDeployed: 1193290511425
lastModified: 1193290511425
mbeans:

org.jboss.deployment.DeploymentInfo@c97846f6 { url=file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/ra.xml }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jboss-ha-local-jdbc/META-INF/ra.xml
altDD: null
lastDeployed: 1193290511440
lastModified: 1193290511425
mbeans:

org.jboss.deployment.DeploymentInfo@c8309f54 { url=file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jndi.properties }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/Program Files/jboss-4.0.5.GA/server/default/deploy/jndi.properties
altDD: null
lastDeployed: 1193290511440
lastModified: 1193290511440
mbeans:




And when i am running my client i am geeting


javax.naming.CommunicationException: Can't find SerialContextProvider
at com.sun.enterprise.naming.SerialContext.getProvider(SerialContext.java:60)
at com.sun.enterprise.naming.SerialContext.<init>(SerialContext.java:79)
at com.sun.enterprise.naming.SerialInitContextFactory.getInitialContext(SerialInitContextFactory.java:54)
at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
at javax.naming.InitialContext.init(Unknown Source)
at javax.naming.InitialContext.<init>(Unknown Source)
at tester.TesterClient.main(TesterClient.java:21)



me my jndi propertiy file is

java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory
java.naming.provider.url=jnp://localhost:1099
java.naming.factory.url.pkgs=org.jboss.naming rg.jnp.interfaces



So can any one please help.Please help me its urgent

Thanks,
Ankush
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10264
    
168

Did you do any changes to the jboss-ha-local-jdbc.rar which is in the deploy folder of the server. The exceptions show that the .rar extension has been removed from this file and as a result no deployer is being found to deploy it. Also, delete the jndi.properties file from the deploy folder.


[My Blog] [JavaRanch Journal]
ankush patni
Greenhorn

Joined: Oct 11, 2007
Posts: 11
Thanks Jai,
I have removed the Jndi property file and kept it out side.But i am still getting error.

Now i again i deployed my simple(Basic application tester.jar) on jboss-4.2.1.GA.

Server is running without any problem.
But when i am running the client name of client is TesterClient then it is not able to fine mind my Home interface. error's i am getting are

javax.naming.CommunicationException [Root exception is java.lang.ClassNotFoundException: tester.TesterHome (no security manager: RMI class loader disabled
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:730)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:589)
at javax.naming.InitialContext.lookup(Unknown Source)
at tester.TesterClient.main(TesterClient.java:22)
Caused by: java.lang.ClassNotFoundException: tester.TesterHome (no security manager: RMI class loader disabled)


can you please tell me what is going wrong.
Please help me its very urgent.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10264
    
168

You will have to place the remote/local/home interfaces of the bean in the client's (TesterClient) classpath.
ankush patni
Greenhorn

Joined: Oct 11, 2007
Posts: 11
Thanks Jai,
NOw it is working fine.My first program is working fine.
 
jQuery in Action, 2nd edition
 
subject: Error whiling running the server