Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to Deploy EAR file in JBoss 4.2.1

 
Abhijith Prabhakar
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am deploying an .ear to JBoss 4.2.1GA. The .ear contains an exploded .war and 2 .jar with EJBs. The exploded .ear deploys OK. However, when I deploy the zipped (i.e. unexploded) .ear I get the following exception:
org.jboss.deployment.DeploymentException: Failed to find module file: AnADD-WebModule.war

When I unzip the .ear, it deploys again fine.

My application.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<application xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee<br /> <a href="http://java.sun.com/xml/ns/j2ee/application_1_4.xsd"" target="_blank" rel="nofollow">http://java.sun.com/xml/ns/j2ee/application_1_4.xsd"</a> version="1.4">
<display-name>AnADD</display-name>
<module>
<web>
<web-uri>AnADD-WebModule.war</web-uri>
<context-root>/AnADD-WebModule</context-root>
</web>
</module>
<module>
<java>anaddEjb.jar</java>
</module>
<module>
<java>supportEjb.jar</java>
</module>
</application>

Does anybody know how to solve this please??
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you have the zipped version of the ear, run the following command from the command prompt and post the output here:
First 'cd' to the deploy folder from the command prompt and run this command



Note: Replace myApp.ear with the appropriate ear name, in the command

Also, while posting the output here, remember to wrap the contents in a 'code' block by using the Code button in the message editor window.
[ December 31, 2007: Message edited by: Jaikiran Pai ]
 
Abhijith Prabhakar
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have given the output here
 
Abhijith Prabhakar
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I just found out that, if I deploy exploded WAR the application deploys fine. Ant script for this is given below

But, If I build a normal EAR using <ear> target, then it doesn't deploy and gives the above said reason. Ant Script for this is given below


Any specific reason for this??
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic