File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes JBoss/WildFly and the fly likes JBOSS - Disable HTTP Proxy Server Caching Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBOSS - Disable HTTP Proxy Server Caching" Watch "JBOSS - Disable HTTP Proxy Server Caching" New topic

JBOSS - Disable HTTP Proxy Server Caching

C Deepak

Joined: Dec 12, 2007
Posts: 4
I am using JBoss in a private network. Some of my application requests are routed to Internet through my Gateway which then passes through our HTTP Proxy to the internet. HTTP requests to other machines in private network works fine till any of my application accesses internet through HTTP Proxy. Once it hits the HTTP Proxy, thereafter any http request from jboss, by default, gets forwarded to HTTP Proxy (got to know from ethereal logs).

Ideally it should have been routed inside my private network itself. Since the destined machine address is not resolvable by our HTTP Proxy, connection eventually times out. I understand this behavior is due to some caching of HTTP Proxy details in JBoss (hope am not wrong here itself).

I did some dig around in disabling cache but of no help. Can some one please let me know how to disable caching of proxy details in jboss?

Sincerely appreciate your response.


Note: I cannot put entries in my HTTP Proxy to route back as it is not under my control. Therefore, I should restrict on JBoss itself from forwarding requests to the proxy unless only it needs to go out to internet.
Jaikiran Pai

Joined: Jul 20, 2005
Posts: 10441

Hello "Deepak"

Welcome to JavaRanch We are pleased to have you here.

We have a naming policy at JavaRanch. Your displayed name must consist of a first name (or an initial), a space, and a family name (in that order) and not be obviously fictitious. Please take a moment to change it, which you can do right here.

Thank you

[My Blog] [JavaRanch Journal]
C Deepak

Joined: Dec 12, 2007
Posts: 4
Thanks, Jaikiran. I have done the same.

Now, waiting for any positive soln to my problem

I agree. Here's the link:
subject: JBOSS - Disable HTTP Proxy Server Caching
It's not a secret anymore!