File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes IBM RAD, stops after 50 secs, starting jboss 4.2.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "IBM RAD, stops after 50 secs, starting jboss 4.2.1" Watch "IBM RAD, stops after 50 secs, starting jboss 4.2.1" New topic
Author

IBM RAD, stops after 50 secs, starting jboss 4.2.1

Jesus Angeles
Ranch Hand

Joined: Feb 26, 2005
Posts: 2049
Hi,

I am starting jboss from inside IBM RAD.

It stops after 50 seconds with error:

"Timeout waiting for JBOSS 4.2 to start. Server did not start after 50s.
"

It starts okay (same jboss folder) when I start it inside netbeans 6.

Any ideas?
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9930
    
159

I guess this there is a timeout configured in IBM RAD. If the server takes longer than that then it throws this error. You probably have to increase that timeout or disable it.


[My Blog] [JavaRanch Journal]
Rajeev R Tumkur
Greenhorn

Joined: Sep 13, 2007
Posts: 17
Hi,
I have not used RAD. But, I believe that it is similar to Eclipse. Try the below steps.

1. In the menu bar of Eclipse/RAD, go to windows -- > Preferences --> Server --> Server time-out delay.

2. Select the option Long /Longer in the drop down list. Default is Normal (time-put period of 50 seconds). Long has timeout period of 100 seconds & Longer has timeout period of 200 seconds.

3. Then click O.k. & restart the server.

Hope this helps.


_ _____________ _ <br />Regards,<br />Rajeev
Jesus Angeles
Ranch Hand

Joined: Feb 26, 2005
Posts: 2049
Thanks guys. It worked.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: IBM RAD, stops after 50 secs, starting jboss 4.2.1
 
Similar Threads
Error while publishing webSphere 6.0 server in RAD7
Another One from Threads...
Trouble starting jboss-eap-4.3.0.GA_CP06
RMI Registry stop after timeout
JBoss Time Out Error in Eclipse