aspose file tools*
The moose likes JBoss/WildFly and the fly likes Starting JBoss as windows service. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Starting JBoss as windows service." Watch "Starting JBoss as windows service." New topic
Author

Starting JBoss as windows service.

krishnamohan murugesan
Greenhorn

Joined: May 27, 2008
Posts: 5
I am using jboss 4.0.5GA.I want to start JBoss as windows service so that
whenever i restart JBoss gets automatically started.how to do it?
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9343
    
111

krishnamohan,

Welcome to JavaRanch

Follow these instructions for starting JBoss as a service using JBossNative. You can download the appropriate JBossNative version from here


[My Blog] [JavaRanch Journal]
krishnamohan murugesan
Greenhorn

Joined: May 27, 2008
Posts: 5
Thanks Jai.
But while starting JBoss as windows service i got an error message that JAVA_HOME is not set.But i has configured in system path and when i start JBoss using run.bat there is no problem.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9343
    
111

Originally posted by krishnamohan murugesan:

But while starting JBoss as windows service i got an error message that JAVA_HOME is not set.


Please post the entire error message that you see. Where do you see this error message? Try setting the JAVA_HOME in the run.bat and see if it works. Here's a small portion from the run.bat, in which i am setting the JAVA_HOME:

Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5779
    
    7

When setting JAVA_HOME, make sure you set it in the "System variables" and not in "User variables for xxx". If you run the JBossAS service as the SYSTEM account, or under its own account, it will prick up the "System variables' but not the user variables for your account.


JBoss In Action
krishnamohan murugesan
Greenhorn

Joined: May 27, 2008
Posts: 5
Thank all.
Initially i has set JAVA_HOME in user variables..now it is working fine.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Starting JBoss as windows service.
 
Similar Threads
To start JBoss Service without any console in desktop
Jboss start on system bootup
JBoss as a Windows service
Starting jboss automatically after booting the machine.
start jboss-4.2.2.GA in windows service