wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes JBoss startup dependency not working? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss startup dependency not working?" Watch "JBoss startup dependency not working?" New topic
Author

JBoss startup dependency not working?

Perry Langostine
Greenhorn

Joined: Jun 06, 2008
Posts: 6
I have an MDB that uses the IBM MQ resource adapter. In the server logs, I can see that my MDB is loaded before the RAR for MQ. If I deploy my app after JBoss and the RAR are running, all is well. If I start JBoss with my app already deployed, I get an exception:

I believe I have set the dependencies up correctly:

JBoss 5 beta 4 doesn't seem to heed the dependency instructions in my mbean, excerpted here:


Is this a known issue, or am I doing something wrong here?

TIA.
Perry
Perry Langostine
Greenhorn

Joined: Jun 06, 2008
Posts: 6
Turned out to be a JBoss startup dependency issue here:

http://jira.jboss.com/jira/browse/EJBTHREE-1199

Hope this helps others who follow.

Perry
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JBoss startup dependency not working?
 
Similar Threads
javax.naming .NameNotFoundException:
Problem integrating Jboss with IBM MQ using JCA resource adaptors
Exception: max connections reached
MDB exception: InstanceNotFoundException wmq.jmsra.rar not registered.
IBM Websphere v6 and JBoss 4x MQ Connectivity - Please Help