This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Multiple Struts-config.xml in Jboss 4.2.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Multiple Struts-config.xml in Jboss 4.2.1" Watch "Multiple Struts-config.xml in Jboss 4.2.1" New topic
Author

Multiple Struts-config.xml in Jboss 4.2.1

jeff rusty
Ranch Hand

Joined: Nov 07, 2006
Posts: 109
Hi all,
I have just upgradee to Jboss 4.0.2 from 4.2.1 GA and when i use two struts-config.xml in my web application i get a problem that my second struts-config.xml is not at all recognised by my application server the same code isworking fine in 4.0.2. i am using struts1.2 with web2.3 and my web.xml looks lie this
<servlet>
<servlet-name>action</servlet-name>
<servlet-class>
org.apache.struts.action.ActionServlet
</servlet-class>

<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml,/WEB-INF/struts-config- menu.xml</param-value>
</init-param>
<init-param>
<param-name>debug</param-name>
<param-value>3</param-value>
</init-param>
<init-param>
<param-name>detail</param-name>
<param-value>3</param-value>
</init-param>

<load-on-startup>0</load-on-startup>
</servlet>

i also tried something like this stilll its not workig
<servlet>
<servlet-name>action</servlet-name>
<servlet-class>
org.apache.struts.action.ActionServlet
</servlet-class>

<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
<init-param>
<param-name>config/menu</param-name>
<param-value/WEB-INF/struts-config- menu.xml</param-value>
</init-param>

<init-param>
<param-name>debug</param-name>
<param-value>3</param-value>
</init-param>
<init-param>
<param-name>detail</param-name>
<param-value>3</param-value>
</init-param>

<load-on-startup>0</load-on-startup>
</servlet>
any help would be appreciated.

thanks,
jeff
[ June 18, 2008: Message edited by: jeff rusty ]
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9924
    
158

i get a problem that my second struts-config.xml is not at all recognised by my application server


Do you see any errors? If yes, then post them here.


[My Blog] [JavaRanch Journal]
jeff rusty
Ranch Hand

Joined: Nov 07, 2006
Posts: 109
no i dont get any errors. The browser goes to a blank page.

Jeff
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9924
    
158

You will either have to look in the server.log or the console. Without the logs or error messages, it hard to tell where the problem is.
jeff rusty
Ranch Hand

Joined: Nov 07, 2006
Posts: 109
The problem i doesnt search for the entry in the second struts-config.xml
how to configure to access the second struts-config.xml

jeff
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Multiple Struts-config.xml in Jboss 4.2.1
 
Similar Threads
The method doMarkDoneOutboundCall(null, String) is undefined for the type Done_jsp
Struts Action Param
Unable to utilize Application Resources
help with module level struts config
Need related struts subapps in one struts app