wood burning stoves 2.0*
The moose likes JBoss/WildFly and the fly likes JBoss compiles, but doesn't run on server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss compiles, but doesn Watch "JBoss compiles, but doesn New topic
Author

JBoss compiles, but doesn't run on server

Heather Rose
Ranch Hand

Joined: Aug 25, 2008
Posts: 54
I am using MyEclipse, JDK/JRE 1.6, JBoss4.2.2.GA, Ant1.6.5.
I have successfully set up my environmental variables for JAVA_HOME and ANT_HOME. As I recall, I do not need a variable for JBOSS_HOME.

The problem I am having is that I run my ant scripts for my project, and that works successfully. Then, I try to Run on Server using JBoss, and it successfully starts up. Then, I try to get to my page (I'm using port 8080).

The URL for the normal JBOSS page is: http://localhost:8080.
This comes up fine. There is nothing on the same port, as I have checked that already.

When I put in my project name afterwards, it gives me a Page not Found error. http://localhost:8080/MYPROJECTNAME.

Am I missing some libraries or have I not set something up correctly?
Heather Rose
Ranch Hand

Joined: Aug 25, 2008
Posts: 54
There are 4 errors that I receive:

2 ClassNotFoundExceptions, and a 2 DeploymentExceptions.

--- Incompletely deployed packages ---
org.jboss.deployment.DeploymentInfo@ba4e3e51 { url=file:/C:/jboss-4.2.2.GA/server/default/deploy/dobi2.ear }
deployer: org.jboss.deployment.EARDeployer@93c4f1
status: Deployment FAILED reason: URL file:/C:/jboss-4.2.2.GA/server/default/tmp/deploy/tmp63392dobi2.ear-contents/dobi2-exp.war/ deployment failed
state: FAILED
watch: file:/C:/jboss-4.2.2.GA/server/default/deploy/dobi2.ear
altDD: null
lastDeployed: 1219786311204
lastModified: 1219786309708
mbeans:
jboss.j2ee:ear=dobi2.ear,jar=jboss-seam.jar,name=TimerServiceDispatcher,service=EJB3 state: Started
jboss.j2ee:ear=dobi2.ear,jar=jboss-seam.jar,name=EjbSynchronizations,service=EJB3 state: Started

--- MBeans waiting for other MBeans ---
ObjectName: jboss.j2ee:service=EJB3,module=dobi2.jar
State: FAILED
Reason: java.lang.ClassNotFoundException: Unexpected error during load of: com.savageservices.dobi.ap.session.impl.APEntryBean, msg=Bad version number in .class file

ObjectName: jboss.web.deployment:war=dobi2.war,id=1983415159
State: FAILED
Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-4.2.2.GA/server/default/tmp/deploy/tmp63392dobi2.ear-contents/dobi2-exp.war/ deployment failed

--- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
ObjectName: jboss.j2ee:service=EJB3,module=dobi2.jar
State: FAILED
Reason: java.lang.ClassNotFoundException: Unexpected error during load of: com.savageservices.dobi.ap.session.impl.APEntryBean, msg=Bad version number in .class file

ObjectName: jboss.web.deployment:war=dobi2.war,id=1983415159
State: FAILED
Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-4.2.2.GA/server/default/tmp/deploy/tmp63392dobi2.ear-contents/dobi2-exp.war/ deployment failed


Those are the errors I get. Please someone help.
Rene Larsen
Ranch Hand

Joined: Oct 12, 2001
Posts: 1179

Maybe you can use this: Bad version number in .class file


Regards, Rene Larsen
Dropbox Invite
Heather Rose
Ranch Hand

Joined: Aug 25, 2008
Posts: 54
That helped! I found out what was wrong. Thanks!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JBoss compiles, but doesn't run on server