File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes mdb doesn't catch messages in point2point Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "mdb doesn Watch "mdb doesn New topic
Author

mdb doesn't catch messages in point2point

Esteban Sanchez
Greenhorn

Joined: Mar 25, 2008
Posts: 4
Hello,

I'm trying to send messages to a mdb from a JSF backing-bean in JBoss 4.2.3. I'm including below all the code I've added to my app to get this running. The problem is, the method onMessage in the mdb MDBInitImport never gets called.

Here is the code I have so far:

In the backing-bean



The mdb



The jbossmp-destinations-service.xml



Thank you very much for your help
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5772
    
    7

I tried your code and it works for me. I used JBossAS 4.2.2 with JDK 1.5.0_16.

Are you getting any stack traces in the console log?


JBoss In Action
Esteban Sanchez
Greenhorn

Joined: Mar 25, 2008
Posts: 4
Hi,

thanks for your answer. Nothing in the console.

I'm using JBoss 4.2.3 with default configuration and Richfaces 3.2.1.

Could it be the cause, a wrong server configuration?. I didn't change anything from config files so JBoss has all the testing queues etc. Should I change to "minimal" JBoss configuration?.

Cheers
Martijn Verburg
author
Bartender

Joined: Jun 24, 2003
Posts: 3274
    
    5

Have you tried looking on the JMS console to see if the Queue is correctly registered and that messages are on it?


Cheers, Martijn - Blog,
Twitter, PCGen, Ikasan, My The Well-Grounded Java Developer book!,
My start-up.
Esteban Sanchez
Greenhorn

Joined: Mar 25, 2008
Posts: 4
No messages in the queue according to the console. But the queue is there. Am I missing a config param or something in some config file?

Thanks
Martijn Verburg
author
Bartender

Joined: Jun 24, 2003
Posts: 3274
    
    5

Try posting a message to that queue and see if it stays there (it should). If the message then disappears then chances are your MDB (or another client to the Queue) is taking that message.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: mdb doesn't catch messages in point2point
 
Similar Threads
Unable to deploy MDB in Jboss.
MDB not recieving the message not throwing any exception
Singleton MDB in a clustered environment
[EJB3]MessageDriven bean never catch message
Jboss Remote Connection JMS