• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

NoClassDefFoundError org hibernate persister entity EntityPersister

 
siddiq syed
Greenhorn
Posts: 6
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

When ever i deploy the EAR in JBoss instance it gives me the error
java.lang.NoClassDefFoundError for Hibernate.

Applications runs fine when i run in my local server and with the same instance when i am trying to run in another server/remoter server it gives me the error
java.lang.NoClassDefFoundError: org/hibernate/persister/entity/EntityPersister and some times it give me the error

My EAR contains a JAR and a WAR.
and if we see the order of deployement in org.jboss.deployment.MainDeployer-xmbean.xml is



and hibernate3.jar is present in C:\JBOSS Server\server\CONSServer\lib

Any help is really appreicated.

Regards
Siddiq.
 
Jair Rillo Junior
Ranch Hand
Posts: 114
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First of all, are you using Hibernate-core or JPA using Hibernate implementation?

Looking at the error, I guess you're tyring to use JPA. Hence, only the hibernate3.jar file is not enough. There are a lot of others JARs file required. Also, you will need to download the Hibernate-annotation and Hibernate-EntityManager packages.

If you wanna a simple example of how to setup the JPA and Hibernate (with all required JARs files), you can check this post: http://www.jairrillo.com/blog/2008/09/04/introduction-to-jpa-part-1-getting-started/. Put those JARs files into classpath and try to redeploy your application.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic