This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Other Java Products and Servers and the fly likes EMSRV not starting Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "EMSRV not starting" Watch "EMSRV not starting" New topic
Author

EMSRV not starting

Veni Velkoor
Ranch Hand

Joined: Oct 17, 2001
Posts: 65
Hi,
Not sure where to post this but here goes--
I am trying to install EMSRV on a Win2K Pro m/c. I set up a EMSRV
administrator to start/stop etc and gave this user the following access as
per the documnetation
Act as part of the operating system
Logon as a service
Logon locally
Access this computer from the network
This user also has Administrator pivileges on this computer. Now when I try
to start the EMSRV server from its working directory C:\Program
Files\IBM\EMSRV , using the command emsrv -u userid -p password
I get the following error--------------------------------
>EMSRV started at 15:10:17 on 03/04/02 on port 4800
>Running as a service: No
>Maximum number of concurrent connections: 512
> Logging level: Error
>Log file name: emsrv.log
>Allow connections to truncate repositories: Yes
>File system requires read locks: No
>File system releases locks: Yes
>Authentication: Disabled
> Seconds to wait for a lock: 1
>Working directory: C:\Program Files\IBM\EMSRV
>EMSRV: AdjustTokenPrivileges error setting privileges. OS error 1300: Not
all privileges referenced are assigned to the caller.
>EMSRV: Logon error for user emsrvadm, check password. OS error 1314: A
required privilege is not held by the client.
>EMSRV: Check that the EMSRV user account has sufficient privileges.
>EMSRV: Unloading...
I am not sure which other privileges I am mmissing-- Please advice, I
haven't seen any doc. mention any other priv.
Thanks in Advance.
Veni.
Ozge Y
Greenhorn

Joined: Aug 07, 2002
Posts: 1
It's not enough for your user to have the administrator priviliges.You also have to give it the "Act as part of an operating system" privilage.
I hope this will help you to give that privilige:
To authorize the EMSRV user to start the repository server on Windows NT:
- Log in to Windows NT as an Administrator.
From the Start menu, select Programs > Administrative Tools (Common) > User Manager. The User Manager dialog box will appear.
If desired, create a new user to be the EMSRV user.
- Still in the User Manager dialog box select User Rights from the Policies menu. (It does not matter which user's name is selected when you do this.) The User Rights Policy dialog box will appear.
- Select Show Advanced User Rights and then click the downarrow to see the Right pull-down list. The list should now include "Act as part of the operating system".
- Select Act as part of the operating system from the list, and click OK.
- The Grant To pane will list the users who currently have this privilege. Click Add. The Add Users and Groups dialog box will appear.
- Click Show Users. Scroll down the list of users in the Names pane and select the EMSRV user from the list.
- Click Add. The EMSRV user's name will appear in the Grant To pane at the bottom of the Add Users and Groups dialog box. Click OK.
- The EMSRV user's name now appears in the Grant To pane of the User Rights dialog box. Click OK.
To authorize the EMSRV user to start the repository server on Windows 2000:
- From the Start menu, select Settings > Control Panel. Double-click Administrative Tools.
Double-click Local Security Policy. The Local Security Settings window opens.
- Double-click Local Policies. From the list that opens, select User Rights Assignment. In the right-hand pane, you will see a list of all the operating system properties.
- Double-click Act as part of the operating system. The Local Security Policy Setting dialog opens.
- Click Add. The Select Users or Groups dialog opens.
- Select the EMSRV user and click Add. Click OK.
- The dialog closes. The EMSRV user appears in the Local Security Policy Setting dialog. Click OK.
- Log off as Administrator and log back on as Administrator. You must do this, otherwise, the property will not be set properly.
- To verify the property has been set properly, follow steps 1 to 4 and ensure that both the "Local Policy Setting" and "Effective Policy Setting" check boxes are selected for the EMSRV user.
- The EMSRV user now has the Windows operating system privileges needed to start the repository server. If the user can not start EMSRV successfully, shut down Windows on the server and reboot the machine. It is sometimes necessary to take this action before changes in Windows privileges take effect.
Take care.


Software Developer<br />Computer Engineer
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: EMSRV not starting
 
Similar Threads
Jboss When run as service not able to access local system path
web sphere portal enable
Installing Websphere single server edition v4.0
HELP!!--EMSRV in VAJ not starting
Urgent help please !!!!!!!! - Http server is not starting !!!