This week's book giveaway is in the OCAJP forum.
We're giving away four copies of OCA Java SE 8 Programmer I Study Guide 1Z0-808 and have Jeanne Boyarsky & Scott Selikoff on-line!
See this thread for details.
The moose likes Other Java Products and Servers and the fly likes Using JNI with iPlanet 6.1 - UnsatisfiedLinkError exception Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA Java SE 8 Programmer I Study Guide 1Z0-808 this week in the OCAJP forum!
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "Using JNI with iPlanet 6.1 - UnsatisfiedLinkError exception" Watch "Using JNI with iPlanet 6.1 - UnsatisfiedLinkError exception" New topic
Author

Using JNI with iPlanet 6.1 - UnsatisfiedLinkError exception

Douglas Kent
Ranch Hand

Joined: Oct 06, 2000
Posts: 171
Hello,
Using a JNI module in a JSP page, running under iPlanet 6.1 on Windows 2000 server. It compiles just fine, but when run, getting "UnsatisfiedLinkError", indicating that the JVM can't find the dll. I have tried putting the directory where the dll resides in the classpath of the Java settings for the server instance, putting the directory in the "PATH" environmental variable, putting it in the "CLASSPATH" environmental variable, have registered the dll with regsvr32. Has anyone encountered this problem and gotten a solution?

thanks in advance!
 
Don't get me started about those stupid light bulbs.
 
subject: Using JNI with iPlanet 6.1 - UnsatisfiedLinkError exception