This week's book giveaway is in the Cloud/Virtualizaton forum.
We're giving away four copies of Mesos in Action and have Roger Ignazio on-line!
See this thread for details.
Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JNDI issue: "domain was null"

 
Chris Reeves
Ranch Hand
Posts: 95
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, Orion wizards. Try this one...
I am calling an orion instance remotely with a command line client with success. I add the jar with my ejb's in it and orion.jar to the path, and I set the jndi params explicitly in the code...

This works perfectly.
So, I slap this into a servlet, which I have in a webapp, and in turn inside orion.
When I call the servlet, I get the following error:
java.lang.NullPointerException: domain was null
at com.evermind._bp._rhc(.:477)
at com.evermind._bp._jmb(.:546)
at com.evermind.server.rmi.RMIInitialContextFactory.getInitialContext(.:159)
at com.evermind.server.ApplicationClientInitialContextFactory.getInitialContext(.:156)
at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
at javax.naming.InitialContext.init(Unknown Source)
at javax.naming.InitialContext.<init>(Unknown Source)
...
What the heck am I doing wrong here?
[ July 24, 2002: Message edited by: Chris Reeves ]
 
leonn leonn
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't know...
 
Moody Hopkins
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Found this on another site and this fixed it for me!

http://otn.oracle.com/tech/java/oc4j/904/collateral/OC4J-FAQ-EJB-904.html
[Accessing EJBs, node 15]

Good luck!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic