Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Moving from jdk 1.4 to jdk 1.5

 
Jag Bains
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have just recompiled all my code using JDK1.5.0_03 and now when I try to deploy it on Orion I get the following error:

Auto-deploying petardsCMS-ejb.jar (ejb-jar.xml had been touched since the previous deployment)... PetardsFacade_StatelessSessionBeanWrapper0.java:2: cannot access java.rmi.NoSuchObjectException
bad class file: c:\jdk1.5.0_03\jre\lib\rt.jar(java/rmi/NoSuchObjectException.class)
class file has wrong version 49.0, should be 48.0
Please remove or make sure it appears in the correct subdirectory of the classpath.
import java.rmi.NoSuchObjectException;
^
1 error
Error compiling C:\sandbox\java\deploy\petardsCMS/petardsCMS-ejb.jar: Syntax error in source
Orion/2.0.2 initialized

Any Ideas?
 
Jag Bains
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Realised that I had to copy the latest version of tools.jar
 
Marilyn de Queiroz
Sheriff
Posts: 9063
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Glad you posted your solution, Jag.
 
Thomas Schmitt
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes, thanks very much indeed!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic