aspose file tools*
The moose likes Other Java Products and Servers and the fly likes Ant deployment on iAS 6.5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "Ant deployment on iAS 6.5" Watch "Ant deployment on iAS 6.5" New topic
Author

Ant deployment on iAS 6.5

Richard Green
Greenhorn

Joined: Jan 03, 2003
Posts: 4
Hi all,
I encountered the following error when I run the ant script on iAS 6.5:
Ant script
<target name="deploy_adaconnectorjar" depends="undeploy_adaconnectorjar">

<echo message="Executing iasdeploy to register ${adaconnectorjar}."/>
<exec dir="${assemble}" executable="${ias.bin}/iasdeploy">
<arg line="deploymodule -verbose ${adaconnectorjar}"/>
</exec>
</target>
Error:
D:\AIMS\src\build.xml:1470: Execute failed: java.io.IOException: CreateProcess:
c:\iplanet\ias6\ias\bin\iasdeploy removemodule -verbose cgsAdaConnectorModule.ja
r error=2
java.io.IOException: CreateProcess: c:\iplanet\ias6\ias\bin\iasdeploy removemodu
le -verbose cgsAdaConnectorModule.jar error=2
at java.lang.Win32Process.create(Native Method)
at java.lang.Win32Process.<init>(Win32Process.java:66)
at java.lang.Runtime.execInternal(Native Method)
at java.lang.Runtime.exec(Runtime.java:551)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Exec
ute.java:390)
at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:247)
at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:213)
at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:154)
at org.apache.tools.ant.Target.execute(Target.java:142)
at org.apache.tools.ant.Project.runTarget(Project.java:818)
at org.apache.tools.ant.Project.executeTarget(Project.java:532)
at org.apache.tools.ant.Project.executeTargets(Project.java:506)
at org.apache.tools.ant.Main.runBuild(Main.java:420)
at org.apache.tools.ant.Main.main(Main.java:149)
I did not hit this error when I run the script on iAS 6.0. Neither did I encounter any problem when I run the following line command in iAS6.5.

D:\AIMS\src>c:\iplanet\ias6\ias\bin\iasdeploy removemodule -verbose cgsAdaConnec
torModule.jar
Would appreciate if you guys could throw some light on overcoming this problems.
Many thanks in advance.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Ant deployment on iAS 6.5