It's not a secret anymore!
The moose likes Other Java Products and Servers and the fly likes Ant task  ejbjar for Websphere Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "Ant task  ejbjar for Websphere" Watch "Ant task  ejbjar for Websphere" New topic

Ant task ejbjar for Websphere

prasad Chandrasekaran Iyer

Joined: Jan 14, 2004
Posts: 18
Has anyone tried using ejbjar task for websphere application.
I require code for developing deployment descriptor using ejbjar
I am facing problem creating jar file
following is the code

<ejbjar srcdir="${build.classes.dir}" descriptordir="${tmp.ejb.descriptor.websphere.dir}" basejarname="${profinance.ejb.basename}">
<include name="*-ejb-jar.xml"/>
<websphere ejbdeploy="false"
<pathelement location="${was5.home}/deploytool/itp/plugins/org.eclipse.core.boot_2.0.2.1/boot.jar"/>
<pathelement location="${was5.home}/deploytool/itp/plugins/"/>
<pathelement location="${was5.home}/lib/xerces.jar"/>
<pathelement location="${was5.home}/lib/ivjejb35.jar"/>
<pathelement location="${was5.home}/lib/j2ee.jar"/>
<pathelement location="${was5.home}/lib/vaprt.jar"/>
<path refid="build.classpath"/>
<dtd publicId="-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN" location=""/>
Bug Menot

Joined: Oct 15, 2004
Posts: 26
Does that work at all for you? I'm doing something similar and it doesn't fail, but also doesn't seem to do anything.

In the mean time you way want to look at using ejbdeploy.bat (which comes with was) and execing it from within your script.
Vincy Kaczanowski

Joined: Sep 22, 2005
Posts: 19
I am getting following error when doing ejbjar task,using wsad5.1.2

[ejbjar] building ejb.jar with 42 files
[ejbdeploy] Input options error: The input filename must end in '.jar' or '.ear'. It was C:\Documents..
[ejbdeploy] 0 Errors, 0 Warnings, 0 Informational Messages
I agree. Here's the link:
subject: Ant task ejbjar for Websphere
It's not a secret anymore!