wood burning stoves*
The moose likes Testing and the fly likes Is JUnit 4.1 providing any other compatable files to run on j2sdk 1.4.2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Testing
Bookmark "Is JUnit 4.1 providing any other compatable files to run on j2sdk 1.4.2" Watch "Is JUnit 4.1 providing any other compatable files to run on j2sdk 1.4.2" New topic
Author

Is JUnit 4.1 providing any other compatable files to run on j2sdk 1.4.2

sai prasanna
Ranch Hand

Joined: May 02, 2005
Posts: 167
hi
i have another dought that is JUnit 4.1 providing any other compatable files to run on j2sdk 1.4.2

thanks in advance
saiprasanna
Ilja Preuss
author
Sheriff

Joined: Jul 11, 2001
Posts: 14112
No. JUnit 4 only works with annotations, which were introduced in Java 5. You need to use JUnit 3.x for earlier Java versions.


The soul is dyed the color of its thoughts. Think only on those things that are in line with your principles and can bear the light of day. The content of your character is your choice. Day by day, what you do is who you become. Your integrity is your destiny - it is the light that guides your way. - Heraclitus
sai prasanna
Ranch Hand

Joined: May 02, 2005
Posts: 167
thanks preuss
Ilja Preuss
author
Sheriff

Joined: Jul 11, 2001
Posts: 14112
You're welcome! And please call me Ilja...
 
Consider Paul's rocket mass heater.
 
subject: Is JUnit 4.1 providing any other compatable files to run on j2sdk 1.4.2
 
Similar Threads
while running junit it is throwing java.lang.Unsupported Class Version Error
Using "Tiger" for SCJD 1.4
Netbeans 6 and JUnit 4
CachedRowSet ClassCastException
connecting JSP to SQL Server