• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

Getting Eclipse to work with J2EE

 
Ranch Hand
Posts: 904
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

Im trying to import a J2EE project into Eclipse, but I get a lot of errors
which (I think) is because my eclipse is set up to using J2SE. I've got
J2EE installed in C:\Sun\AppServer.

Alot of errors are regarding the javax.jms (can not be found).

In the preferences menu I've changed the "JRE_LIB" variable to
c:\Sun\AppServer\jdk\jre\lib\rt.jar

Do I need to add anything else?

Thanks in advance,

/Svend Rost
 
author & internet detective
Posts: 41502
881
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Svend,
You need to have two separate entries in your classpath. The original JRE_LIB covers core Java. Then you can add a new classpath entry/variable for J2EE.
 
Svend Rost
Ranch Hand
Posts: 904
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Jeanne,

thanks for your reply.

I've added the new entry, and the errors are gone

Thanks.

/Svend Rost
reply
    Bookmark Topic Watch Topic
  • New Topic