• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Problems with Using ReportWriter

 
Ranch Hand
Posts: 2038
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
All these lines of code say they can't be resolved in WebSphere.

import com.ibm.xsl.composer.flo.*;
import com.ibm.xsl.composer.areas.*;
import com.ibm.xsl.composer.framework.*;
import com.ibm.xsl.composer.java2d.*;
import com.ibm.xsl.composer.prim.*;
import com.ibm.xsl.composer.properties.*;
import com.ibm.as400.util.reportwriter.processor.*;
import com.ibm.as400.util.reportwriter.pdfwriter.*;
 
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Perhaps you just need to add a missing JAR or two to the build path of your IDE. (For example, jt400.jar contains com.ibm.as400.util.CommandHelpRetriever and so jt400.jar must be present in the build path in order to use CommandHelpRetriever. I don't know what JARs or other resources contain the classes you're missing.)

Sometimes adding libraries such as JARs to the build path is as simple as copying JAR files to the WEB-INF/lib folder within your project, if it's a web application.

I'm assuming you just need help configuring your IDE, so I'm moving this to the IDEs forum...
 
Steve Dyke
Ranch Hand
Posts: 2038
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have got this issue resolved. However, when I try to run this in my app I get an error:

[6/25/07 12:18:25:580 CDT] 0000003b ServletWrappe E SRVE0068E: Could not invoke the service() method on servlet ReportProcesserServlet. Exception thrown : java.lang.NoClassDefFoundError: org/apache/xerces/framework/XMLParser

My Servlet Code:



My Class Code:

 
I was born with webbed fish toes. This tiny ad is my only friend:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic