Win a copy of Beginning Java 17 Fundamentals: Object-Oriented Programming in Java 17 this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Unable to load tag handler class using NetBeans 5.5.1

 
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello!

I am trying to create a custom tag (tld) and a tag-handler class using NetBeans 5.5.1. The problem is the IDE can't locate (or load) the tag hanler class. I have checked the tld URI, class name and location but still don't know what is the problem. Any help very much appreciated. Below is the detail code for taglib, handler and jsp:



//testLib.tld




//TwoDigitsTag




//index.jsp


To mention, I get a big fat error in this line "<test:TwoDigitsTag num="<%= tempC %>" of index.jsp

</body>
</html>
 
Ranch Hand
Posts: 959
Eclipse IDE Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I don't know why I can't insert the code here

Anyway, you forgot the enclose your custom tag with />. Everything is fine except for that.
[ July 19, 2007: Message edited by: Freddy Wong ]
 
Mahi Rahman
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

you forgot the enclose your custom tag with />.



Hi Freddy, I can't locate the mistake. Could you tell me the line number and which class.
 
Sheriff
Posts: 26963
84
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It's the line that you posted in bold yourself. As Freddy said, you didn't close the tag properly.
 
reply
    Bookmark Topic Watch Topic
  • New Topic