• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

ANT_HOME variable for Windows XP

 
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
Im a newbie to ant .I was trying to follow the instruction sun j2ee 1.3 tutorial.THE O/S I am using is windows XP
ANT is installed in c:\unzipped
and i am setting ANT_HOME to c:\unzipped but still I am getting an error which says ANT_HOME set incoorectly or not able to find ant.
PLEASE HELP!!!
 
Ranch Hand
Posts: 74
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I don't need to mention that c:\unzipped is a bad location for ANT.

Where did you set the ANT_HOME variable?
You should set it in your windows control panel in the environment variables tab.
If you have an open command window you have to close and reopen it.
 
Venkatesh Kumar
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Peter Storch ,
Thanks for your response.I did set the ANT_HOME using control panel but it is still giving the same error.
Hemanth
 
Peter Storch
Ranch Hand
Posts: 74
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
can you check if "echo %ANT_HOME%" gives you the correct path?
 
Ranch Hand
Posts: 1179
Mac OS X Eclipse IDE
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You need to add '%ANT_HOME%\bin' to your PATH
Rene
 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When you set ANT_HOME in the Environment settings, did you set it for your User Variables or as a System Variable?
Try both of them and see if that works.
 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You might be missing your %ANT_HOME%\lib\ant.jar. I used WinXP to extract the ant-1.6.3 archive and for whatever reason it didn't extract all of the lib folder. I just use the win explorer to drill into the archive and copy and past the jar files. Weird..
 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The same problem i faced. Do not set ANT_HOME. Delete that ant home. Set or add entry to PATH variable <your and home>\bin. Now it will work. Can antbody help me in required set up's and bulid.xml to send mail after the build. Thanks in Advance.........
 
Ranch Hand
Posts: 147
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
@Mohan

I am also facing this issue. I am not clear with what you say:

'Set or add entry to PATH variable <your and home>\bin.'

Please let me know in detail.
 
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey guys,set ANT_HOME to the C:\apache-ant-1.7.1\bin and then add C:\apache-ant-1.7.1\bin;%ANT_HOME%\bin in path ..then it works....

and also I recommned ot to use this way..this way is just to make projects without eclipse ...Use eclipse guys there is no need for this additional work..
 
Saloon Keeper
Posts: 24499
167
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

ashik chollangi wrote:Hey guys,set ANT_HOME to the C:\apache-ant-1.7.1\bin and then add C:\apache-ant-1.7.1\bin;%ANT_HOME%\bin in path ..then it works....

and also I recommned ot to use this way..this way is just to make projects without eclipse ...Use eclipse guys there is no need for this additional work..



Actually, Eclipse isn't nearly as flexible as Ant (or Maven) at building complex projects. So I often use Ant inside Eclipse.

But I seriously recommend that any good project be buildable without using an IDE, even if it's just an option. I've been burned too many times where I couldn't do a build because either my IDE was the wrong version or because it didn't have exactly the same desktop settings as someone else's IDE. Batch builds are less tempermental. Plus they can run on non-gui machines.
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Wow, a 6-year old zombie...

Anyway, in case someone else trips over this in the future, this advice is incorrect:

set ANT_HOME to the C:\apache-ant-1.7.1\bin



For this example, ANT_HOME should be set to C:\apache-ant-1.7.1 (leave off "\bin").

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
This worked for me !!
 
reply
    Bookmark Topic Watch Topic
  • New Topic