• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Pvcs Ant

 
Ranch Hand
Posts: 354
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Trying to access PVCS repository on UNIX mapped from NT.
The Z:/pvcs_67 contains .cfg file.
I have done a SET PCLI_ID=userid assword on command prompt.
Can you tell what is wrong here?
thanks
The script is :
<project name="ProductManager" default="pvcs.get" basedir=".">
<property name="pvcs.repository" value= "Z:/pvcs_67" />
<target name="pvcs.get">
<echo message="Getting Product Master files from PVCS" />
<pvcs repository="${pvcs.repository}" force="yes">
</pvcs>
</target>
</project>
and the result :
pvcs.get:
[echo] Getting Product Master files from PVCS
[pvcs] Executing 'pcli' with arguments:
[pvcs] 'lvf'
[pvcs] '-z'
[pvcs] '-aw'
[pvcs] '-prZ:/pvcs_67'
[pvcs] '/'
[pvcs]
[pvcs] The ' characters around the executable and arguments are
[pvcs] not part of the command.
[pvcs] PVCS Version Manager (PCLI) v7.5.1.0 (Build 297) for Windows NT/80x8
6
[pvcs] Copyright 1985-2002 MERANT. All rights reserved.
BUILD FAILED
file:C:/work/test/build.xml:5: Failed executing: pcli lvf -z -aw -prZ:/pvcs_67 /
at org.apache.tools.ant.taskdefs.optional.pvcs.Pvcs.execute(Pvcs.java:23
4)
at org.apache.tools.ant.Task.perform(Task.java:319)
at org.apache.tools.ant.Target.execute(Target.java:309)
at org.apache.tools.ant.Target.performTasks(Target.java:336)
at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
at org.apache.tools.ant.Project.executeTargets(Project.java:1250)
at org.apache.tools.ant.Main.runBuild(Main.java:610)
at org.apache.tools.ant.Main.start(Main.java:196)
at org.apache.tools.ant.Main.main(Main.java:235)
[ December 18, 2003: Message edited by: Jonathan Harker ]
 
Ranch Hand
Posts: 466
1
IntelliJ IDE Oracle Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am also getting the below error while trying to fetch the code from PVCS. Any pointers how this could be solved?

Thanks
Vinod

Abhinav Srivastava wrote:Trying to access PVCS repository on UNIX mapped from NT.
The Z:/pvcs_67 contains .cfg file.
I have done a SET PCLI_ID=userid assword on command prompt.
Can you tell what is wrong here?
thanks
The script is :
<project name="ProductManager" default="pvcs.get" basedir=".">
<property name="pvcs.repository" value= "Z:/pvcs_67" />
<target name="pvcs.get">
<echo message="Getting Product Master files from PVCS" />
<pvcs repository="${pvcs.repository}" force="yes">
</pvcs>
</target>
</project>
and the result :
pvcs.get:
[echo] Getting Product Master files from PVCS
[pvcs] Executing 'pcli' with arguments:
[pvcs] 'lvf'
[pvcs] '-z'
[pvcs] '-aw'
[pvcs] '-prZ:/pvcs_67'
[pvcs] '/'
[pvcs]
[pvcs] The ' characters around the executable and arguments are
[pvcs] not part of the command.
[pvcs] PVCS Version Manager (PCLI) v7.5.1.0 (Build 297) for Windows NT/80x8
6
[pvcs] Copyright 1985-2002 MERANT. All rights reserved.
BUILD FAILED
file:C:/work/test/build.xml:5: Failed executing: pcli lvf -z -aw -prZ:/pvcs_67 /
at org.apache.tools.ant.taskdefs.optional.pvcs.Pvcs.execute(Pvcs.java:23
4)
at org.apache.tools.ant.Task.perform(Task.java:319)
at org.apache.tools.ant.Target.execute(Target.java:309)
at org.apache.tools.ant.Target.performTasks(Target.java:336)
at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
at org.apache.tools.ant.Project.executeTargets(Project.java:1250)
at org.apache.tools.ant.Main.runBuild(Main.java:610)
at org.apache.tools.ant.Main.start(Main.java:196)
at org.apache.tools.ant.Main.main(Main.java:235)
[ December 18, 2003: Message edited by: Jonathan Harker ]

 
author
Posts: 3281
8
Mac OS X Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hmm, I doubt the OP will see that as they posted in 2003!

I'd try running with the ANT debug flag set to true and/or try the PVCS forums (if no-one else answers here).
 
He does not suffer fools gladly. But this tiny ad does:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic