• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Ant

 
Ranch Hand
Posts: 84
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello,
iam new to programming can any one tell how can i install apache-ant-1.6.5
to use tomcat 5.5.9 on linux
when i tried to install it
in bash_profile i enered
PATH=$PATH:${ANT_HOME}/bin:$HOME/bin
JAVA_HOME=$HOME/apps/java
CATALINA_HOME=$HOME/apps/jakarta-tomcat-5.5.9
ANT_HOME=$HOME/apps/apache-ant-1.6.5

copied catalina-ant.jar from tomcat/server/lib to apache-ant-1.6.5/lib
when i tried ant -version got error
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/Launcher


please help me!
anuja
 
Saloon Keeper
Posts: 22484
151
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're making a forward reference to ANT_HOME. Set the PATH last, not first.
 
anuja Edathu
Ranch Hand
Posts: 84
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thank u tommy,
my ant is now working i could create and compile a program .
my next problem is to copy that to tomcat/webapps/WEB-INF/class
how i tried it writting copy task but some how its not working
any answer
 
Rancher
Posts: 43016
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

but some how its not working



What does this mean? Is it executed? Do you get any error messages? Does it copy the wrong files? Does it copy them a wrong location? Showing us the section of your Ant script that does the copying would also help.
 
anuja Edathu
Ranch Hand
Posts: 84
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi friends i could solve my problem.
thanks for your help
regards
Anuja
 
    Bookmark Topic Watch Topic
  • New Topic