Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Testing using ANT

 
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The build.file I use for the example application is as follows. The compilation goes thru, but not the testing.

Could you please help? The message is just Build successful.


 
Saloon Keeper
Posts: 25782
184
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The problem most people have is that they have to tell Ant where the JUnit jar is, since it doesn't come in automatically. But I think that's supposed to give an exception.

Try ant with the "-v" option: "ant -v test" and see if it tells you anything more.
 
Sunder Ganapathy
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Tim. After using -v option I get the following message.

C:\tomcat\apache-tomcat-6.0.14\webapps\newselen>ant -v test

Apache Ant version 1.7.0 compiled on December 13 2006 Buildfile: build.xml
Detected Java version: 1.6 in: C:\Program Files\Java\jdk1.6.0\jre
Detected OS: Windows XP
parsing buildfile C:\tomcat\apache-tomcat-6.0.14\webapps\newselen\build.xml with
URI = file:/C:/tomcat/apache-tomcat-6.0.14/webapps/newselen/build.xml

Project base dir set to: C:\tomcat\apache-tomcat-6.0.14\webapps\newselen

[antlib rg.apache.tools.ant] Could not load definitions from resource org/apache/tools/ant/antlib.xml. It could not be found.

[property] Loading C:\tomcat\apache-tomcat-6.0.14\webapps\newselen\build.properties
Build sequence for target(s) `test' is [test]
Complete build sequence is [test, report, compile, ]

test:

BUILD SUCCESSFUL
Total time: 1 second
[ April 10, 2008: Message edited by: Sunder Ganapathy ]
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic