• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

mvn deploy over ssh prompts for password

 
Ranch Hand
Posts: 58
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I'm having problems getting maven 2.0.9 deploy goal to work over ssh. Every time I trigger mvn deploy I'm being asked to provide password (about 6 times for each deploy). The client pc is a windows XP machine and the repository is running on a linux server. My settings.xml looks like this

<server>
<id>snapshots<id>
<username>tester</username>
<password>12345</password>
</server>

and my pom.xml has the following entry

<distributionManagement>
<snapshotRepository>
<id>snapshots</id>
<name>Snapshot</name>
<url>scp://192.168.1.3/var/www/repo/snapshots</url>;
</snapshotRepository>
</distributionManagement>

Unfortunately I haven't got direct control over the server so I don't really know how ssh is configured (if the problem is on that end). I ran a similar test at home where the client pc was a winXP and I installed a default installation of openSSH on a debian linux box without changing any settings. I didn't have any problems running mvn deploy from the client machine which makes me wonder if something needs to be configured on the server side.

Thanks
S
 
Saloon Keeper
Posts: 25453
178
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
ssh uses Unix/Linux shell accounts, so the userid and password are as defined for interactive users. About the only gotcha would be if the account had been configured on the server in a way that denied shell logins - for example if the "login shell" assigned to the account was the "/bin/false" program instead of "/bin/sh".
 
Sven Anderson
Ranch Hand
Posts: 58
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks for your reply,

I'll need to check with sysadmin tomorrow. I can run putty and winscp from my computer but maybe that hasn't got anything to do with how the linux user accounts been set up in relation to my problem with mvn deploy.

First I wasn't sure if maven was reading the local settings.xml file but after adding invalid xml syntax to the settings.xml maven complained.

Thanks
 
That feels good. Thanks. Here's a tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic