Win a copy of Micro Frontends in Action this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Ant script not finding my build.properties file

 
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I have my ant Script, I am working through the spring tutorial.

The build.properties and build.xml are on the same level in my springapp package, but anytime it tries to read a value from the build.properties file, it comes up with any error.

Here is my ant Script

xml version="1.0"?

and here is the build.properties

appserver.home=${user.home}/apache-tomcat-6.0.18

appserver.lib=${appserver.home}/lib

deploy.path=${appserver.home}/lib

tomcat.manager.url=http://localhost:8080/manager
tomcat.manager.username=tomcat
tomcat.manager.password=s3cret


When I run ant, i get this error message

BUILD FAILED
C:\Documents and Settings\se1025\workspace\springapp\build.xml:87: C:\Documents
and Settings\se1025\workspace\springapp\${application.lib} not found.



i get this error when I run ant list if I substitue ${appserver.lib}with the value C:/apache-tomcat-6.0.18. It builds, then I run ant list and get this


list:


[ August 27, 2008: Message edited by: Sege Stephen ]
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try running ant with the -v option, this might tell you a little more about what is going on.
[ August 27, 2008: Message edited by: Peter Johnson ]
 
So you made a portal in time and started grabbing people. This tiny ad thinks that's rude:
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic