• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Liutauras Vilda
  • Paul Clapham
Sheriffs:
  • paul wheaton
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Piet Souris
Bartenders:
  • Mike London

Internet Explorer - error messages

 
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Internet explorer gives error message like

"The page contains both secure and non secure item, do you want to display non secure item"

In this situation, when i click yes or no, nothing display in the page. Page cannot be display error, or Action cancelled error.

I suspect this error because of iframe, currently i am using iframe.

My iframe is
String mainFrame ="abc.do?event=search&clearSearch=true";

<iframe name="adminframe" width="100%" height="100%" src="<%=mainFrame%>" name="main" frameborder="no"></iframe>

Is there any solution to bypass that error message. Or how to change the iframe

Thanks in advance
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It sounds like you have two issues.

The first is a normal warning that will happen any time to link to non-secure resources (images, etc..) from a secure page.
Also an empty "src" attribute in an image tag or iframe will cause that.

Second, once you agree, it sounds like your app is blowing up.
MSIE will hide the real error messages coming from the server for you.
To change this, click on Tools -> Internet Options -> Advanced and uncheck the "Show Friendly HTTP Errors" item. You may need to restart the browser for this to take effect.
 
Sheriff
Posts: 67694
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I see no JSP dimension to this question. Moved to the HTML forum.
 
author
Posts: 15385
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Your iframe needs to be in the https domain along with all of the images, style sheets, JavaScript files, and so on.
reply
    Bookmark Topic Watch Topic
  • New Topic