• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Kind attn. Mr Ajith

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,
I have downloaded cocoon1.8 version from apache and tried to deploy it on Orion application server.I have configured the web.xml and modified the class path to access the jar files of cocoon over that of orion. Following is the content of .bat file which I am using to set the class path..
*********************************************************
rem Cocoon classes and libraries
set ORION_HOME = c:\orion;
set CLASSPATH=.
set CLASSPATH=%CLASSPATH%;c:\orion\xerces_1_2.jar
set CLASSPATH=%CLASSPATH%;c:\orion\xalan_1_2_D02.jar
set CLASSPATH=%CLASSPATH%;c:\orion\fop_0_15_0.jar
set CLASSPATH=%CLASSPATH%;c:\orion\cocoon.jar
set CLASSPATH=%CLASSPATH%;c:\orion\turbine-pool.jar
set CLASSPATH=%CLASSPATH%;c:\orion\cocoon-filter.jar
set CLASSPATH=%CLASSPATH%;c:\orion\xalantrax.jar
set CLASSPATH=%CLASSPATH%;c:\orion\stylebook-1.0-b2.jar
set CLASSPATH=%CLASSPATH%;c:\orion\webserver.jar
set CLASSPATH=%CLASSPATH%;c:\orion\jasper.jar
set CLASSPATH=%CLASSPATH%;c:\orion\parser.jar
set CLASSPATH=%CLASSPATH%;c:\orion\xml.jar
set CLASSPATH=%CLASSPATH%;c:\orion\tools.jar
set CLASSPATH=%CLASSPATH%;c:\orion\servlet_2_2.jar
****************************************************
While trying to execute the index.xml of the cocoon application I am getting the follwing error..
************************************************
Publishing Engine could not be initialized.
java.lang.RuntimeException: Error loading logicsheet at resource://org/apache/cocoon/processor/xsp/library/java/util.xsl due to java.lang.Exception: Resource not found or retrieving error.
at org.apache.cocoon.processor.xsp.XSPProcessor.init(XSPProcessor.java:302)
at org.apache.cocoon.framework.Manager.create(Manager.java:109)
at org.apache.cocoon.framework.Router.init(Router.java:80)
at org.apache.cocoon.framework.Manager.create(Manager.java:109)
at org.apache.cocoon.Engine.<init>(Engine.java:179)
at org.apache.cocoon.Engine.getInstance(Engine.java:232)
at org.apache.cocoon.Cocoon.init(Cocoon.java:157)
at com.orionsupport.cocoon.CocoonServlet.init(CocoonServlet.java:52)
at com.evermind.server.http.HttpApplication.w1(JAX)
at com.evermind.server.http.HttpApplication.wj(JAX)
at com.evermind.server.http.HttpApplication.w6(JAX)
at com.evermind.server.http.HttpApplication.getNamedDispatcher(JAX)
at com.orionsupport.cocoon.CocoonFilter.cocoonDispatcher(CocoonFilter.java:99)
at com.orionsupport.cocoon.CocoonFilter.doFilter(CocoonFilter.java:72)
at com.evermind.server.http.ey.xv(JAX)
at com.evermind.server.http.ey.su(JAX)
at com.evermind.server.http.ef.s1(JAX)
at com.evermind.server.http.ef.do(JAX)
at com.evermind.util.f.run(JAX)
*****************************************************
I have done a search through the mail archive of Java ranch and found a tip posted by Ajith Kallambella the moderrator. I tried with the Chapter 9 Web Publishing Frameworks from Orielly. But I am not able to set the proper logicsheets for the sample application.I have ensured that cocoon.jar contains the corresponding class files and xsl files.I am sure u guys should come up with a solution to my problem .
Thanx and Regards
Pradeep Kumar
 
Don't sweat petty things, or pet sweaty things. But cuddle this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic