• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Jj Roberts
  • Carey Brown
Bartenders:
  • salvin francis
  • Frits Walraven
  • Piet Souris

SSL issue

 
Ranch Hand
Posts: 186
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello JavaCoders,

I've implemented a java client program that connects to a Web Service over SSL/https to fetch data. When running the completed application on a Windows JDK 1.4.2 it works just as expected.

But when its deployed to an AS400 server running JDK 1.4.2 I get the following error:


Why is this happening?
When I google Ive realized that this is a common problem when running JDK 1.3, but that the JSSE packages are part of the JDK 1.4 release.

Any help is more than welcome!

Kind regards
 
Bartender
Posts: 1638
IntelliJ IDE MySQL Database Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Does this this faq entry help?
 
Rancher
Posts: 43016
76
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Nitesh Kant:
Does this this faq entry help?


Probably not, as that entry specifically mentions that this ceased to be a problem with JDK versions 1.4 and newer.
 
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello
The AS400 server ... You may be dealing with an IBM JVM, or perhaps something other than a Sun JVM? You may find out by running "java -v". Find out whether crypto tools are not bundled because of US export laws, or otherwise.
Cheers.
 
Dominic Steng�rd
Ranch Hand
Posts: 186
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey again,

Have found what the problem is and thought you guys might want to know how to solv this IBM AS400 issue.

Did some googling and ran some tests and it turns out that the IBM JVM 1.4 doesnt have the JSSE support that is included in the Sun JVM 1.4. This implies that one has to fetch the IBMJSSE jar and have it configured in the java.security file for this JVM.

More info can be found at:
http://apps.cybersource.com/library/documentation/dev_guides/Web_Services_Clients_Java/html/app_adv_config.htm

Have a fantastic Java Coding Week!!
 
I guess everyone has an angle. Fine, what do you want? Just know that you cannot have this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic