This week's book giveaway is in the Cloud/Virtualization forum.
We're giving away four copies of Pipeline as Code and have Mohamed Labouardy on-line!
See this thread for details.
Win a copy of Pipeline as Code this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Rob Spoor
  • Henry Wong
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh
  • Jj Roberts

Problem launching app through web-server

 
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've developed an application that I would like to launch via webstart. Running the application locally via:



works fine. The application launches with no problem. The jar file also runs fine if I run it using:



However, when I put the same JAR and JNLP file (edited to match the updated directory location) in the webserver directory, I get a java.lang.NoClassDefFoundError exception. Here's the JNLP file:



I'm using the new swing-layout-1.0.jar file (from Netbeans Matisse) and it's included in the JExcel.jar file in a /lib directory. Like I said, it all runs fine when I run the jar file from a command line. My question is this: why does it run fine from the command line but won't run from my web-server?

Thanks,
Dave
[ February 24, 2006: Message edited by: David Irwin ]
 
Ranch Hand
Posts: 476
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I think it has something to do with signing the jars. I've read that if you have third party jar file, in order to use it in your webstart application you need to sign it. But you can't because it's not yours. There are couple of solution, one of them is to create another jnlp file in which you refer to the third party jar file and in turn use that jnlp in your main jnlp.
This also might be helpful: http://forum.java.sun.com/thread.jspa?threadID=704775&messageID=4086848
 
Would anybody like some fudge? I made it an hour ago. And it goes well with a tiny ad ...
SKIP - a book about connecting industrious people with elderly land owners
https://coderanch.com/t/skip-book
reply
    Bookmark Topic Watch Topic
  • New Topic