• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

document/literal webservice axis complex-type:Attempted to write schema for bad QName

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

I have written the following webservice

1) server-side (Skeleton): PflanzenschutzNameServer.java

2) einer wsdd-datei: (ausschnitt: das service-tag


The webservice is deployd on the server and if i try to connect with my Client (Stub) to the service, everything is fine

My problem:

my webservice must be document/literal, because I don't use an own Client but a Client integrated in Infopath (Microsoft Office Tool, which must have an document(literal-webservice). This means, that the service-tag in the wsdd-file must contain the attributes
.
I've tried it also with style=�wrapped�, but Infopath seems not to understand the wrapped-style.

If I try to deploy my webservice (wsdd-file) with
.
axis 1.1 could not create a wsdl-file, so I can't call my service:-(
axis shows the following error if i try to view the wsdl-file on
http://localhost:8080/axis/services/Pflanzenschutz?wsdl:



This only happens, if my webservice-method returns a complex type like an aaray of strings (String[]). If the service returns a single String instead of an array everything seems to work fine.

Can anybody tell me, where my mistake is?

thank you for your help!!!

tine
 
author and deputy
Posts: 3150
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I once tried "Axis array type webservice + Infopath" but it never worked.
But i have not tried it with the newer versions of Axis.

Solution 1: Use the latest infoapth 2003 sp1, yes it has vs.net has managed code, works great with axis or any tool.

Solution 2: Try to use MSSOAP libs inside your infopath js scripts.

Solution 3: Try to correct the error that occurs when you use document/iilteral option. May be try to generate the "proper" WSDD using Java2WSDL utility and then redeploy the service.

Let me know how it goes..
 
pie. tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic