Win a copy of Pipeline as Code this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Rob Spoor
  • Henry Wong
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh
  • Jj Roberts

i need help please!

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
well ,, it all started suddenly without any changes..
everything was working fine until it stop responding .. let me tell you the story:
i programmed an applet that connects to a visual basic program the applet acts like a client the VB is the server .. the thing is that i want the control the VB program using Internet Explorer.. i used Java applet to reach this goal..
as i said .. everything was fine .. i could watch the applet from another pc using the IP of the actual web server (LAN WEB SERVER) that has the applet and class and everything in a single directory
no .. i couldn't ! .. without changing any thing ..
i usually use a laptop to watch and access the applet .. it has sdk installed and everything was fine .. no i get this error:
java.lang.ClassNotFoundException:VB6Applet
as i mentioned .. the full package is in the same folder ..and i have many copies of it .. they all give me the same result..
i got the actual server .. i duoble clicked on the html page of the applet .. and it runs fine (but doesn't connect to the VB .. nevermind leave it for now) but, when i access the page from by using the IP of the server .. i can't reach .. i could reach other files in the web server .. but that particular file is not accessing it. i tried re installing everything .. sdk .. web server .. same result.
what i did then is i uploaded the files to one of the sites on the internet ..
if i used the actual server to access this new uploaded files .. i get the same error .. if i used the client i normally use .. i get the same error ... but one of my friends could successfully access it!
i think there is something wrong with my client and server .. but the question is ... what?

i hope everything is clear, and i really appreciate any kind of help.
thanks in advance
 
Who among you feels worthy enough to be my best friend? Test 1 is to read this tiny ad:
SKIP - a book about connecting industrious people with elderly land owners
https://coderanch.com/t/skip-book
reply
    Bookmark Topic Watch Topic
  • New Topic