This week's book giveaway is in the Artificial Intelligence and Machine Learning forum.
We're giving away four copies of TensorFlow 2.0 in Action and have Thushan Ganegedara on-line!
See this thread for details.
Win a copy of TensorFlow 2.0 in Action this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Paul Clapham
  • Bear Bibeault
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • salvin francis
  • Scott Selikoff
  • fred rosenberger

1.4 or 5

 
Ranch Hand
Posts: 105
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I booked for SCJP 5 and my friend booked for SCJP 1.4 , yesterday.
( both of us are planning to take it in an year .)

I felt its reasonable to take the recent version rather than updgrading it later...spending another 100$

She said the reasons for her choice of 1.4:

1. There aren't enough materials to prepare for 5
2. She already started preparing for 1.4, so not wanting add more to it..
3. Since 1.4 exam is there for almost (X) years now, people can understand that she has this certification since (2007-X)...and If she takes 5 now, there is a chance for them to guess, she knows java only since....200Y ( when sun initited exams for 5)

etc......

Now, am confused..Replies are appreciated..

Thanks!!

PS: I don't know X and Y, Someone please fill the blanks

[ June 25, 2007: Message edited by: Ais Kaly ]
[ June 25, 2007: Message edited by: Ais Kaly ]
 
Sheriff
Posts: 11343
Mac Safari Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Ais Kaly:
...There aren't enough materials to prepare for 5...


I think 1.5 is in its prime now, and there should not be any difficulty in finding materials.

Originally posted by Ais Kaly:
......Since 1.4 exam is there for almost (X) years now, people can understand that she has this certification since (2007-X)...and If she takes 5 now, there is a chance for them to guess, she knows java only since....200Y ( when sun initited exams for 5)
...


Hmmm... By that reasoning, wouldn't 1.1 be the most valuable? :roll: Holding an old certification does not necessarily mean x years of experience. It's about what you know, not how long you've known it, and Java 1.5 has a lot of valuable new features. (I'm certified in 1.4, and I feel like I'm overdue for upgrading.)
[ June 25, 2007: Message edited by: marc weber ]
 
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yup, it seems that she'll had to look for new reasons to do 1.4

In my opinion is more valuable to take the Java 5 cert, bucause you know all the new features the language has.
 
Ranch Hand
Posts: 893
Tomcat Server Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just do the 1.5 version. The reasons given for the 1.4. version are not valid.

A reason for choosing the 1.4. version would be that in general this version is considered easier.
 
Oscar Gonzalez
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, but that depends for me the exam 5 is easier, you have to memorize fewer things like the keywords and the exact values the primitives can take.
 
Ranch Hand
Posts: 332
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I used study materials for both, 1.4 and 1.5.

1. There are a lot of materials available.
2. Sooner or later 1.5 will come to use, in companies where now only 1.4 is used.
3. Having experience and having certificate are 2 different things. Also 1.5 certificate can demonstrate your ability to learn new things.
 
Ranch Hand
Posts: 213
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was faced with this problem a year and a half ago. I think Java 5 should be the overwhelming option at this point, but that's just my opinion.
 
Ranch Hand
Posts: 247
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got the SCJP designation 2 months, and a new job.

When I interviewed I was asked searching questions about generics and the foreach loop covered only in 1.5.

My advice go for the 1.5
 
Do Re Mi Fa So La Tiny Ad
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic