Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Problem with starting the j2ee server

 
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
Is it not possible to run the j2ee server on Windows 98..does it
requires Windows NT only...pls let me know abt this
bye
Vinay
 
Ranch Hand
Posts: 202
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
J2EE is specific for NT or Windows 2000.
Try using the version for Windows 2000 for your Win98.
Do get back to me if it works.


------------------
Suneel
 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi,
Is it possible on Millennium edition.
smita
 
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello
i have deployed and tested beans on the J2sdkee1.2.x implementation on windows 98. it works fine. so go ahead and enjoy
cheers
Sanjeev
 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
Set your Classpath properly..It works../go to the bin dir of J2sdkee1.2 folder through command prompt and run setenv and then from the same instance of command prompt type j2ee -verbose it"ll work...
Cheers..Johnson
 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Johnson,
I've what you said and it still doesn't work. I'm running Windows 98. Here's my environment settings:
SET JAVA_HOME=C:\jdk1.3.1_01
SET J2EE_HOME=C:\j2sdkee1.3
SET J2EE_CLASSPATH=C:\j2sdkee1.3\lib\j2ee.jar
SET ANT_HOME=C:\jakarta-ant-1.4-bin\jakarta-ant-1.4
I get the following message when I type "j2ee -verbose" at the command prompt:
Syntax error
Syntax error
Syntax error
Java 2 Enterprise Edition Server
Options:
-verbose
-help ...
...
 
Jolly Khanna
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I think I figured it out.
#1) Change setenv.bat
***********OLD*****************
set JAAS_OPTIONS=-Djava.security.auth.policy=%J2EE_HOME%\lib\security\jaas.policy
set SSL_OPTIONS=-Djavax.net.ssl.trustStore=%J2EE_HOME%\lib\security\cacerts.jks
set LISTEN_OPTIONS=-Dcom.sun.CORBA.connection.ORBListenSocket=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:1060
set JAVACMD=%JAVA_HOME%\bin\java -Xmx128m %SSL_OPTIONS% %JAAS_OPTIONS%
*********************************
change the above to
**************NEW*****************
set JAAS_OPTIONS=-Djava.security.auth.policy
set JAAS_OPTIONS1=%J2EE_HOME%\lib\security\jaas.policy
set SSL_OPTIONS=-Djavax.net.ssl.trustStore
set SSL_OPTIONS1=%J2EE_HOME%\lib\security\cacerts.jks
set LISTEN_OPTIONS=-Dcom.sun.CORBA.connection.ORBListenSocket
set LISTEN_OPTIONS1=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:1060
set CLASSPATH=%CLASSPATH%;%CPATH%
set JAVACMD=%JAVA_HOME%\bin\java -Xmx128m
**********************************
#2 Change j2ee.bat
************OLD********************
%JAVACMD% %LISTEN_OPTIONS% -Dorg.xml.sax.parser=org.xml.sax.helpers.XMLReaderAdapter -Dorg.xml.sax.driver=org.apache.crimson.parser.XMLReaderImpl -Djms.home=%JMS_HOME% -Dcom.sun.jms.service.jdbc.dbpath=%JMS_DB_PATH% -Djms.properties=%J2EE_HOME%\config\jms_service.properties -Djava.security.policy==%J2EE_HOME%\lib\security\server.policy -Djava.security.auth.login.config=%J2EE_HOME%\lib\security\login.config -Dcom.sun.enterprise.home=%J2EE_HOME% -classpath %CPATH% com.sun.enterprise.server.J2EEServer %*
***********************************
Change the above to
************NEW********************
%JAVACMD% %SSL_OPTIONS%=%SSL_OPTIONS1% %JAAS_OPTIONS%=%JAAS_OPTIONS1% %LISTEN_OPTIONS%=%LISTEN_OPTIONS1% -Dorg.xml.sax.parser=org.xml.sax.helpers.XMLReaderAdapter -Dorg.xml.sax.driver=org.apache.crimson.parser.XMLReaderImpl -Djms.home=%JMS_HOME% -Dcom.sun.jms.service.jdbc.dbpath=%JMS_DB_PATH% -Djms.properties=%J2EE_HOME%\config\jms_service.properties -Djava.security.policy==%J2EE_HOME%\lib\security\server.policy -Djava.security.auth.login.config=%J2EE_HOME%\lib\security\login.config -Dcom.sun.enterprise.home=%J2EE_HOME% com.sun.enterprise.server.J2EEServer %1 %2
******************************************
Notice that we changed "com.sun.enterprise.server.J2EEServer %*" to
"com.sun.enterprise.server.J2EEServer %1 %2"
*********************
-After making these changes I was able to start my j2ee server on Windows 98.
Good luck!
-Jolly
 
See ya later boys, I think I'm in love. Oh wait, she's just a tiny ad:
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic