• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Paul Clapham
  • Bear Bibeault
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • salvin francis
  • Scott Selikoff
  • fred rosenberger

iplanet

 
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, I know I am asking for too much. But I know there are a lot of knowledgable people here. I am trying to work on iplanet web server, enterprise. It is suppose to be run both servlets and jsp. However I have had so many configuaration problem. There is no proper forum to post this. So if someone have some experience, here is my question:
1. If my servlets do not run (I followed whatever is on the doc), whatelse should I check?
2. If my jsp is 2 layer deeper than the doc root, and is not running, anyway to solve it?
Thanks
 
Trailboss
Posts: 23227
IntelliJ IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm moving this thread to the J2EE forum
(iPlanet does run servlets and JSP - but it isn't easy to get things going)
 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you Check the server logs? I have found them to be vital in debugging problems with the iws. Unfortunately I have not configured iws for servlets but instead used Jrun to process them. Again, check out the logs they will tell you what is wrong
 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Cynthia,
I have implemented Servlet and Jsp on iPlanet 4.1
Beleive me, it is very hard to get that to working even though I have done the Servlets and JSP on WebLogic before.
One thing I could not achieve is run a servlet that has or is under Java Packaging structure. So I had to take the Servlet class out of packaging and deploy.
Let me know if you still need help on running it.
Also the log files help you a lot.
Sarath
 
Ranch Hand
Posts: 124
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Sarath Madap:
One thing I could not achieve is run a servlet that has or is under Java Packaging structure.
Sarath


You can run a packaged servlet but you have to register that servlet and provide a virtual path to it.
 
Bhupinder Dhillon
Ranch Hand
Posts: 124
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Cynthia Yao:
There is no proper forum to post this.
Thanks


Here is the address and port number for their secure news server:
url - secnews.netscape.com
port - 563
newsgroups - iplanet.server, netscape.dev.jsp, netscape.dev.servlets
 
Cynthia Yao
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks all for helping me. To avoid all problems, I changed everything into jsp pages, which I am more familiar with anyway.
Thank you again
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have just installed iPlanet web server 4.1 and am trying to run jsps on it. But to my surprise I am unable to do so at all. No proper documentation is available and whatever is in the docs provided by iPlanet is either outdated or is talking about some previous version which doesn't even map to the the new interface. Please help me as I am in great hurry. How should I run jsps on iPlanet. My mail id is : manishbalayan@yahoo.com
Thanx
Manish
reply
    Bookmark Topic Watch Topic
  • New Topic