• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Help To fix J2ee_HOME...please

 
Ranch Hand
Posts: 199
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello All,
I am new into this....I just downloaded j2sdk1.2.1.
I have set the following varibles in the userconfig.bat in the bin directory & executed it.
set J2EE_CLASSPATH=C:\j2sdkee1.2.1\lib\j2ee.jar
set JAVA_HOME=C:\jdk1.2.2
And then when I try to run this in Dos
C:\j2sdkee1.2.1\bin > j2ee -verbose
It says...
"ERROR: Set J2EE_HOME to the path of a valid j2sdkee."
Kindly help to fix this......
Also...I am in win 95 platform.
Aruna
 
Ranch Hand
Posts: 424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Goto the bin directory and 'edit' (nearly) all *.bat files.
Open a command-window. cd to that bin directory and
do: j2ee -verbose
and/or deploytool
cloudscape -start
Eventuall add the j2sdk../bin directory to your path-variable
(e.g. in autoexec.bat)
set path=%path%;'path to j2s../bin'
Let me know if it worked?
 
Aru Ven
Ranch Hand
Posts: 199
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Peter,
Thx for ur repsonse....
I have set the class_path & the path But still I'm getting the same old message
"ERROR: Set J2EE_HOME to the path of a valid j2sdkee."
Please help..... And..Can I run on Win 95.....??? Also I am using Jdk1.2.2
Aruna


[This message has been edited by Aru Ven (edited May 08, 2001).]
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Step 1:
change classpath setting in autoexec.bat on your system as follows

set path=c:\j2sdkee1.2.1\bin;%path%;
set JAVA_HOME=c:\jdk1.2.2
set J2EE_HOME=c:\j2sdkee1.2.1
set CPATH=.;%J2EE_HOME%\lib\j2ee.jar
set classpath=c:\j2sdkee1.2.1\lib\j2ee.jar;c:\j2sdkee1.2.1\lib\ejbdeployment10.jar;c:\j2sdkee1.2.1\lib\jhall.jar;%classpath%

step 2:
Go to c:\j2sdkee1.2.2\bin\userconfig.bat and make changes as follows
set JAVA_HOME=c:\jdk1.2.2
Now test it......
 
What do you have in that there bucket? It wouldn't be a tiny ad by any chance ...
a bit of art, as a gift, that will fit in a stocking
https://gardener-gift.com
reply
    Bookmark Topic Watch Topic
  • New Topic