Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Urgent Help Please........

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Friends,
I am facing problem while running a simple program in Weblogic8.1
I started server with JVM 1.4.1
I compiled all my JMS programs with Java1.3.1
And when I am trying to run sample program that I developed I am getting following error.
Please help to solve the problem.
Thanks in advance.
Regards
Ranjit

D:\abc>java com.monex.prototype.SimpleTopicPublisher
Exception in thread "main" java.lang.NoClassDefFoundError: java/lang/AssertionError
at weblogic.security.subject.DelegatingSubjectStack.<clinit>(DelegatingSubjectStack.java:18)
at weblogic.security.service.SubjectManagerImpl.<init>(SubjectManagerImpl.java:40)
at weblogic.security.service.SubjectManagerImpl.ensureInitialized(SubjectManagerImpl.java:277)
at weblogic.jndi.WLInitialContextFactoryDelegate.<clinit>(WLInitialContextFactoryDelegate.java:137)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:120)
at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:131)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:665)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:246)
at javax.naming.InitialContext.init(InitialContext.java:222)
at javax.naming.InitialContext.<init>(InitialContext.java:198)
at com.monex.prototype.SimpleTopicPublisher.main(SimpleTopicPublisher.java:54)
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
set your classpath to have that missing class
 
Ranjit Raje
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks a lot!
But problem still remains the same(Even with classpath details)
My out put is like
D:\abc>javap com.monex.prototype.SimpleTopicPublisher
Compiled from SimpleTopicPublisher.java
public class com.monex.prototype.SimpleTopicPublisher extends java.lang.Object {
public com.monex.prototype.SimpleTopicPublisher();
public static void main(java.lang.String[]);
}
D:\abc>java com.monex.prototype.SimpleTopicPublisher
Exception in thread "main" java.lang.NoClassDefFoundError: java/lang/AssertionError
at weblogic.security.subject.DelegatingSubjectStack.<clinit>(DelegatingSubjectStack.java:18)
at weblogic.security.service.SubjectManagerImpl.<init>(SubjectManagerImpl.java:40)
at weblogic.security.service.SubjectManagerImpl.ensureInitialized(SubjectManagerImpl.java:277)
at weblogic.jndi.WLInitialContextFactoryDelegate.<clinit>(WLInitialContextFactoryDelegate.java:137)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:120)
at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:131)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:665)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:246)
at javax.naming.InitialContext.init(InitialContext.java:222)
at javax.naming.InitialContext.<init>(InitialContext.java:198)
at com.monex.prototype.SimpleTopicPublisher.main(SimpleTopicPublisher.java:54)
 
author
Posts: 11962
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
java.lang.AssertionError was introduced in JDK version 1.4 and WebLogic 8.1 uses JDK 1.4. Would it be possible to run the client with JDK 1.4 as well?
 
Ranjit Raje
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thank You Lasse Koskela,
The error is ractified. I think that was the Classpath error.
Regards
Ranjit
 
reply
    Bookmark Topic Watch Topic
  • New Topic