Last week, we had the author of TDD for a Shopping Website LiveProject. Friday at 11am Ranch time, Steven Solomon will be hosting a live TDD session just for us. See for the agenda and registration link
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

org,omg.CORBA.COMM_FAILURE on startup of J2EE RI

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've installed J2SDK1_3_1_12 & J2SDKEE-1_3_1 (on Windows XP), and I'm getting the following error when attempting to start up the J2EE RI server for the first time (with the -verbose switch):

J2EE server listen port: 1050
Naming service started:1050
org.omg.CORBA.COMM_FAILURE: minor code: 1398079689 completed: No
at com.sun.corba.ee.internal.iiop.ConnectionTable.getConnection(Connecti
onTable.java:176)
at com.sun.corba.ee.internal.iiop.ConnectionTable.getConnection(Connecti
onTable.java:68)
at com.sun.corba.ee.internal.iiop.GIOPImpl.getConnection(GIOPImpl.java:7
0)
at com.sun.corba.ee.internal.corba.ClientDelegate.createRequest(ClientDe
legate.java:641)
at com.sun.corba.ee.internal.corba.ClientDelegate.createRequest(ClientDe
legate.java:583)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolve(InitialNa
mingClient.java:1007)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolveUsingBoots
trapProtocol(InitialNamingClient.java:690)
at com.sun.corba.ee.internal.corba.InitialNamingClient.cachedInitialRefe
rences(InitialNamingClient.java:1088)
at com.sun.corba.ee.internal.corba.InitialNamingClient.resolve_initial_r
eferences(InitialNamingClient.java:981)
at com.sun.corba.ee.internal.corba.ORB.resolve_initial_references(ORB.ja
va:2425)
at com.sun.enterprise.naming.SerialContextProviderImpl.initSerialContext
Provider(SerialContextProviderImpl.java:37)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:233)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)
java.rmi.RemoteException
at com.sun.enterprise.naming.SerialContextProviderImpl.initSerialContext
Provider(SerialContextProviderImpl.java:46)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:233)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)
java.rmi.RemoteException
at com.sun.enterprise.naming.SerialContextProviderImpl.initSerialContext
Provider(SerialContextProviderImpl.java:46)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:233)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)

java.lang.RuntimeException
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:346)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)
Error executing J2EE server ...


I've set up the following environment variables;

JAVA_HOME=c:\jdk1.3.1_12
J2EE_HOME=c:\j2sdkee1.3.1

I also have 'c:\jdk1.1.1_12\bin' & 'c:\j2sdkee1.3.1\bin' on the PATH variable.

Does anyone have any ideas on where I've gone wrong?

Thanks in advance!
[ July 07, 2004: Message edited by: Greg Rance ]
 
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
http://www.wickedlysmart.com/HeadFirst/HeadFirstEJB/HeadFirstEJBNotes.html

-Pradeep
 
Greg Rance
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
My envirounment variables were set as per the bottom of the link (I assume you didn't mean the upper part, since I'm not getting to the stage of trying to run the client, and it's a COMM_FAILURE I'm getting rather than a BAD_OPERATION).

I've just double checked these settings but still no joy...
 
Pradeep Dhavakumar
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have the same OS/j2ee version/path/home as you except JAVA_HOME = C:\j2sdk1.4.2_04.."Maybe" you should use j2sdk instead of jdk.
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
(posting reply, although this topic is old, because other people might find this through google, as I did)

I had the same problem. With J2SE 1.3 I got minor code 1398079689. With J2SE 1.4 I got minor code 201.

After googling for an hour or so I found the following link: http://forum.java.sun.com/thread.jspa?threadID=312342&messageID=1259558

And that suggests that the firewall is blocking something. When I turned off my firewall, that solved the problem. Try it!
 
There were millions of the little blood suckers. But thanks to this tiny ad, I wasn't bitten once.
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic