• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

getting "max open cursors exceeded" from EJB

 
Ranch Hand
Posts: 173
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi, I am using weblogic 6.1 i try to run this process in loop which reads/writes to the database. When the loop size increases it gives me the maximum open cursors exceeded error. I checked and the bean is closing the connection and statements in every loop.
the same code is working fine when i use a normal java class and not an EJB. By the way i am migrating the old process(which uses java class) into an EJB.
The maximum allowed connection inside weblogic is 5. I am the only one using it as it is on the local machine.

Can anyone provide some help regarding this problem.

Thanks
[ July 13, 2004: Message edited by: pervaiz gul ]
 
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Check how many open cursors you DB is configured to allow. It might be set way below the max connections value set by your connection pool (if you are using one) or the number of connections your loop requires.
 
Ranch Hand
Posts: 1209
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Yes, as already suggested you might want to take a look at the max cursor open setting for your database. Weblogic 8.1 has an option to switch on prepared statement cache. We used to see this error when the cache was on and it went away when it was switched off. but ofcourse switching off the cache w'd lower performance.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic